Last Comment Bug 672662 - Provide a chrome registration flag for the platform version
: Provide a chrome registration flag for the platform version
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Philipp Kewisch [:Fallen]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-19 15:10 PDT by Philipp Kewisch [:Fallen]
Modified: 2011-08-28 01:54 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix - v1 (2.50 KB, patch)
2011-07-19 15:10 PDT, Philipp Kewisch [:Fallen]
dtownsend: review+
Details | Diff | Splinter Review

Description Philipp Kewisch [:Fallen] 2011-07-19 15:10:43 PDT
Created attachment 546923 [details] [diff] [review]
Fix - v1

When supporting more then one application, its often more convenient for an extension to specify which platform version their binary component is compatible to. This patch adds a "platformversion" chrome registration flag that acts similar to the appversion flag.
Comment 1 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2011-07-20 08:51:02 PDT
Comment on attachment 546923 [details] [diff] [review]
Fix - v1

Dave, what do you think of this? This might be a footgun that isn't worth it, but I don't have a strong opinion.
Comment 2 Dave Townsend [:mossop] 2011-08-01 11:15:29 PDT
Comment on attachment 546923 [details] [diff] [review]
Fix - v1

Since we require binary components to be built against a particular platform version I think allowing component selection based on the platform version makes sense, particularly for other apps where the versions don't match.
Comment 3 Philipp Kewisch [:Fallen] 2011-08-10 13:27:50 PDT
Pushed to mozilla-inbound rev e69bb10026f3
Comment 4 Mounir Lamouri (:mounir) 2011-08-11 04:41:43 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/e69bb10026f3
Comment 5 Philipp Kewisch [:Fallen] 2011-08-11 05:08:27 PDT
Thanks! Any chance this could be backported to earlier branches? With this patch it would be possible to support more than two Thunderbird versions at once and the earlier thats possible the better.
Comment 6 Robert Kaiser 2011-08-11 06:05:38 PDT
AFAIK we have documentation of those flags on MDN, so this addition should be mentioned there as well.
Comment 7 Philipp Kewisch [:Fallen] 2011-08-28 01:53:34 PDT
The documentation contained a slight error, the flag is platformversion not geckoversion. I've corrected this at <https://developer.mozilla.org/en/Chrome_Registration#platformversion>

Note You need to log in before you can comment on or make changes to this bug.