mobile version of getfirefox.com doesn't display correct page

VERIFIED FIXED in 3.3

Status

www.mozilla.org
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: John Slater, Assigned: rik)

Tracking

unspecified
Other
Android

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
When I go to getfirefox.com on Firefox for Android, I'm given http://www.mozilla.com/en-US/firefox/fx/ (the panda page) instead of the mobile-optimized one you see if you visit www.mozilla.com on the same device.

Two things to fix:
- getfirefox.com on mobile should show the mobile-optimized page
- we should check other redirects (particularly ones based on mozilla.org) to make sure they're showing the proper page 

We should get this taken care of as soon as possible.
(Reporter)

Comment 1

7 years ago
Also, can we verify that this isn't a regression? As noted in comment #0, it works properly if you go to www.mozilla.com. I'm guessing we just overlooked the other possible URLs when setting this up, but we should double check to make sure something more strange isn't going on.
(In reply to comment #1)
> Also, can we verify that this isn't a regression? As noted in comment #0, it
> works properly if you go to www.mozilla.com. I'm guessing we just overlooked
> the other possible URLs when setting this up, but we should double check to
> make sure something more strange isn't going on.

This is a regression. The  tested both http://getfirefox.com and http://firefox.com on an android mobile device. The latter works fine.
. Ccing James so he can  help fix this.
(Assignee)

Comment 3

7 years ago
So http://getfirefox.com redirects to http://www.mozilla.com/firefox/?from=getfirefox

It's the "?from=getfirefox" part that makes our redirection break.

I have a fix coming.

Updated

7 years ago
Assignee: nobody → anthony
(Assignee)

Comment 4

7 years ago
Committed on trunk with r92736 and r92741.

For QA, the URL to test is http://www-trunk.stage.mozilla.com/firefox/?from=getfirefox

Also, this should redirect www.mozilla.com to www.mozilla.com/{locale}/m
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: qawanted
Resolution: --- → FIXED
(Reporter)

Comment 5

7 years ago
Awesome, thanks Anthony.

Raymond, can you test mozilla.org/firefox on mobile devices too? We should make sure *all* redirects work.
(Assignee)

Comment 6

7 years ago
John: I think you meant mozilla.COM/firefox :) I can already say that mozilla.com/firefox does not yet redirect to /m for locales. It does for en-US. I need to fight with some regular expressions in .htaccess to make that happen. I just wanted to fix this quickly.
(Reporter)

Comment 7

7 years ago
I actually really did mean mozilla.org/firefox, since that will be the main URL once we do the merge. Should I file a new bug for that and the other redirect stuff you mentioned in comment #6?

Comment 8

7 years ago
John, do you have Phony installed on your Firefox? I noticed I was redirected to the desktop panda page only after I installed the add-on (my Phony is set to default)
(Reporter)

Comment 9

7 years ago
Nope, I don't have Phony.
qa-verified trunk http://www-trunk.stage.mozilla.com/firefox/?from=getfirefox on an Andrioid mobile device
Keywords: qawanted
(Assignee)

Comment 11

7 years ago
Pushed to stage/production with r92843.
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.