Stack trace on /ja/groups/reviewers

VERIFIED FIXED in 2011-07-26

Status

support.mozilla.org
Users and Groups
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: rrosario, Assigned: rrosario)

Tracking

unspecified
2011-07-26

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
Traceback (most recent call last):

  File "/data/www/support.mozilla.com/kitsune/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/support.mozilla.com/kitsune/apps/groups/views.py", line 38, in profile
    'leader_form': leader_form or AddUserForm()})

  File "/data/www/support.mozilla.com/kitsune/vendor/src/jingo/jingo/__init__.py", line 76, in render
    rendered = render_to_string(request, template, context)

  File "/data/www/support.mozilla.com/kitsune/vendor/src/jingo/jingo/__init__.py", line 94, in render_to_string
    return template.render(**get_context())

  File "/usr/lib/python2.6/site-packages/jinja2/environment.py", line 891, in render
    return self.environment.handle_exception(exc_info, True)

  File "/data/www/support.mozilla.com/kitsune/apps/groups/templates/groups/profile.html", line 96, in top-level template code
    {{ private_message(user) }}

  File "/data/www/support.mozilla.com/kitsune/apps/groups/templates/groups/base.html", line 4, in top-level template code
    {% set scripts = ('groups',) %}

  File "/data/www/support.mozilla.com/kitsune/templates/base.html", line 91, in top-level template code
    {% block content %}{% endblock %}

  File "/data/www/support.mozilla.com/kitsune/apps/groups/templates/groups/profile.html", line 38, in block "content"
    {{ user_row(user) }}

  File "/data/www/support.mozilla.com/kitsune/apps/groups/templates/groups/profile.html", line 96, in template
    {{ private_message(user) }}

  File "/data/www/support.mozilla.com/kitsune/apps/users/helpers.py", line 64, in private_message
    url=url, msg=msg))

UnicodeEncodeError: 'ascii' codec can't encode characters in position 0-10: ordinal not in range(128)
(Assignee)

Comment 1

6 years ago
https://github.com/jsocol/kitsune/commit/56b6f780afd16396867eaba0b8fef60a2b7036ef
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: 2011-08-02 → 2011-07-26
Verified viewing the reviewers group on /ja no longer triggers a stack trace
Status: RESOLVED → VERIFIED
Duplicate of this bug: 673927
You need to log in before you can comment on or make changes to this bug.