If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Panorama thumbnails do not re-size after a tab or number of tabs in group have been moved or removed

RESOLVED DUPLICATE of bug 625955

Status

Firefox Graveyard
Panorama
RESOLVED DUPLICATE of bug 625955
6 years ago
2 years ago

People

(Reporter: Michael Rabinovsky, Unassigned)

Tracking

8 Branch
x86
Windows 7

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 547085 [details]
Screen shot of the panorama view with the bug pointed out

To recreate: 
1) Create a new group in panorama with two or more tabs
2) Remove a tab from the group
3) Wait/Re-size the group 

The thumbnail of the tab/tabs left behind in the group remained the same size. When resizing the group it still behaved as if it had extra tabs in it. The fact that you removed tabs does not effect the size, panorama seems to not check the size after a tab has been removed.

When you remove a tab panorama should automatically re-size the thumbnails to fit the max size of the group. If you re-size the group the thumbnails should expand to take up all the space they can.

I attached a screen shot of it, the circled areas are areas were there was another tab or tabs before that have been moved but the thumbnail has not been re-sized. You can also see some groups that do not manage the space available to them efficiently.

Note: On the left you can also see Bug 659278 where Panorama uses the same icon cache for all the tabs in a group regardless of their actual content, however this is unrelated to this and completely coincidental.
The tabs left marked group are so small because the space underneath them including some padding is not sufficient to let them resize.

The right group is bug 625955.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 625955
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.