Closed Bug 672809 Opened 8 years ago Closed 8 years ago

7/20 Nightly crashes on startup after update

Categories

(Firefox for Android Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 8

People

(Reporter: mfinkle, Assigned: blassey)

References

Details

Attachments

(2 files)

Just updated to latest Nightly on my Galaxy Tab and I crash during startup in Java. Logcat:

I/ActivityManager( 2504): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App }
I/Launcher( 2610): onPause()
I/ActivityManager( 2504): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=4855 uid=10099 gids={3003, 1015}
I/Launcher( 2610): onWindowFocusChanged(false)
I/global  ( 2504): Default buffer size used in BufferedInputStream constructor. It would be better to be explicit if an 8k buffer is required.
W/ApplicationContext( 4855): Attempt to read preferences file /data/data/org.mozilla.fennec/shared_prefs/App.xml without permission
I/GeckoApp( 4855): create
I/GeckoAppJava( 4855): Checking for an update
I/global  ( 4855): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
D/AndroidRuntime( 4855): Shutting down VM
W/dalvikvm( 4855): threadid=1: thread exiting with uncaught exception (group=0x4001d7d0)
I/        ( 2504): dumpmesg > "/data/log/dumpstate_app_error.log"
E/AndroidRuntime( 4855): FATAL EXCEPTION: main
E/AndroidRuntime( 4855): java.lang.RuntimeException: Unable to start activity ComponentInfo{org.mozilla.fennec/org.mozilla.fennec.App}: java.lang.NullPointerException
E/AndroidRuntime( 4855): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2663)
E/AndroidRuntime( 4855): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2679)
E/AndroidRuntime( 4855): 	at android.app.ActivityThread.access$2300(ActivityThread.java:125)
E/AndroidRuntime( 4855): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:2033)
E/AndroidRuntime( 4855): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime( 4855): 	at android.os.Looper.loop(Looper.java:123)
E/AndroidRuntime( 4855): 	at android.app.ActivityThread.main(ActivityThread.java:4627)
E/AndroidRuntime( 4855): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime( 4855): 	at java.lang.reflect.Method.invoke(Method.java:521)
E/AndroidRuntime( 4855): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:858)
E/AndroidRuntime( 4855): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
E/AndroidRuntime( 4855): 	at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime( 4855): Caused by: java.lang.NullPointerException
E/AndroidRuntime( 4855): 	at org.mozilla.gecko.GeckoApp.onCreate(GeckoApp.java:273)
E/AndroidRuntime( 4855): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1047)
E/AndroidRuntime( 4855): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2627)
E/AndroidRuntime( 4855): 	... 11 more
W/ActivityManager( 2504):   Force finishing activity org.mozilla.fennec/.App


GeckoApp:273 is
http://mxr.mozilla.org/mozilla-central/source/embedding/android/GeckoApp.java#273
Regression from bug 671092 ?
Summary: 7/20 Nightly crashes on Galaxy Tab ( → 7/20 Nightly crashes on Galaxy Tab
Attached patch patchSplinter Review
Assignee: nobody → blassey.bugs
Attachment #547124 - Flags: review?(doug.turner)
Attachment #547124 - Flags: review?(doug.turner) → review+
Summary: 7/20 Nightly crashes on Galaxy Tab → 7/20 Nightly crashes on startup after update
Duplicate of this bug: 672762
When trying to update from 07/20 to 07/21 on Motorola Droid 2 (Android 2.2) I got the error message: "An error occurred when trying to load files required to run Nightly". See the attached screenshot.

Mozilla /5.0 (Android;Linux armv7l;rv:8.0a1) Gecko/20110721 Firefox/8.0a1 Fennec/8.0a1
Attached image The error message.
http://hg.mozilla.org/mozilla-central/rev/4c68066aae83
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 8
Duplicate of this bug: 673113
Unfortunately, the latest nightly, which now includes this fix, still doesn't start.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The new crash is not the same as this one.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
This is not reproducible on the latest nightly
Mozilla /5.0 (Android;Linux armv7l;rv:10.0a1) Gecko/20111027 Firefox/10.0a1 Fennec/10.0a1
updated from
Mozilla /5.0 (Android;Linux armv7l;rv:10.0a1) Gecko/20111026 Firefox/10.0a1 Fennec/10.0a1

HTC Desire
Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.