Closed Bug 672853 Opened 9 years ago Closed 8 years ago

backslashes should be auto-corrected to frontslashes in anchor URLs

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 64488

People

(Reporter: tanner, Unassigned)

Details

Currently, if you click on a link that has a backslash rather than forward slash, you'll likely get a 404. The only type of URI that would ever have a backslash would be on Windows, as a local file. Firefox should correct this to be a regular slash if it's not a local file. Chrome, and IE do this.

Example: http://www-10.lotus.com/ldd/lqwiki.nsf/dx/Using_the_Lotus_Quickr_Connectors - Click on any of the "HTML Version" links. Notice that they have backslashes, and you get a 404. On Chrome, it automatically redirects you to the proper URL, with regular slashes.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 73701
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 73701 ***

That's a SeaMonkey bug. Also, the rationale in that bug is not particularly strong, and it was closed a long time ago, so this may be something to reconsider.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Hrm, it surprises me that Chrome does this. I suppose it may be a side effect of their URI parsing being more lenient in general.
Component: Location Bar → General
Product: Firefox → Core
QA Contact: location.bar → general
Summary: Firefox should auto-correct \s to a / in URLs → backslashes should be auto-corrected to frontslashes in anchor URLs
This is a duplicate.  This has come up several times, but our behavior is in fact correct per current RFCs.  Please feel free to find the original bug and mark this as a duplicate.

And yes, Chrome cloned the IE behavior here, for hierarchical schemes.

When the dust settles on the new URI RFCs, we'll see what things look like.
(In reply to comment #4)
> This is a duplicate.  This has come up several times, but our behavior is in
> fact correct per current RFCs.  Please feel free to find the original bug
> and mark this as a duplicate.

This happened in comment 1, didn't it? This bug was reopened because evidence suggests that we might want to reconsider that long-ago decision, given "things change over time" and all. It seems like we could leave this open to track that RFC dust settling.
> This happened in comment 1, didn't it?

No, that was the wrong bug.  There are core bugs with lots of discussion of trade-offs, including cases that the change would break....

> evidence suggests that we might want to reconsider that long-ago decision

What's the new evidence?  Before, 95% of browsers by usage did this.  Now less than 80% by usage do, right?  Has there been some sort of change in website deployment patterns that makes it more important to make this change?  I'm genuinely curious; I see no new evidence in this bug, so I assume it's out of band somewhere?
No, you're not missing any out-of-band discussion. The "new evidence" that I'm referring to is that Chrome does this. I don't particularly care about this issue, I just don't think it should be resolved a duplicate of an ancient bug whose rationale for being marked INVALID is questionable (there may indeed be a more relevant duplicate, I didn't really look).
(Should this be DUP'd: Bug 231951 ?)
(In reply to Boris Zbarsky (:bz) from comment #6)
> No, that was the wrong bug.  There are core bugs with lots of discussion of

That's bug 64488 I thing, duping
Status: REOPENED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: backslash
You need to log in before you can comment on or make changes to this bug.