Name displayed in From column is inaccurate (changed)

ASSIGNED
Assigned to

Status

Thunderbird
Folder and Message Lists
ASSIGNED
6 years ago
11 months ago

People

(Reporter: rjames@yahoo-inc.com, Assigned: jenzed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [see comment 13 for how to fix this][document comment 13 in sumomo ])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

Look at list in Folder


Actual results:

All bugzilla mails - in the "From" field of the list - say 
  Bugzilla (for Deepak Agarwal)
All, I repeat all, Bugz messages have that same name -- including all old bugz emails from months ago, and all new emails.  They used to have different names.


Expected results:

  Bugzilla (for John Doe)
is actually in the header -- this should show in the list, too.

(I look at the header by doing "Forward".)

(I think this is a regression in 5.0)

Comment 1

6 years ago
Did you have an extension that did this? Mozilla bugzilla e-mail doesn't have anything special for the From field other than the bugzilla daemon address.
(Reporter)

Comment 2

6 years ago
We (Yahoo) probably have lots of extensions.  (I have asked the internal maintainers to look into it.)

Still, if the Header has one name (a valid name), why the consistently bogus one in the List?  (There are 3 Deepak Agarwals in the company; none sound like they are involved in Bugz.)

Comment 3

6 years ago
Does going into preferences, advanced, reading & display tab, and unchecking "show only display names..." fix it? If so, this is a dup.
(Reporter)

Comment 4

6 years ago
Grrr...  It was ThunderBird's Address book deciding that all emails from bugs@... should be labeled as coming from that one person.  I cleared the flag in the address book, and all is well, even old emails.

You could either close this bug report, or ponder whether the Address book is too aggressive.

Re Comment 3 :  I don't know.  The Address book was a good fix for me.

Comment 5

6 years ago
I'm going to mark this incomplete, because I don't know how the display name got set incorrectly in the address book. And you can always turn off the option to use display name. Roughly speaking, there are two sorts of people - those who want control over the display name, and want to see that in the message area and message list, and the other people who don't want that, and we have a pref with UI to control that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE

Comment 6

6 years ago
(In reply to comment #5)
> I'm going to mark this incomplete, because I don't know how the display name
> got set incorrectly in the address book.

Contacts from previous versions of Thunderbird will default to showing the display name from the address book, since there's no way to tell what the user wants for those contacts, and that's how the message header has shown display names since 3.0 at least.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Updated

6 years ago
Summary: From changed → Name displayed in From column is inaccurate (changed)

Updated

6 years ago
Duplicate of this bug: 673351

Comment 8

6 years ago
It's unfortunate that this is causing confusion - see the duplicate - but I'm sure if the behavior were the other way around (i.e. always prefer the header name), I'm sure there'd be reports about Thunderbird not respecting the user's settings.

Maybe this needs to be documented in some prominent place; where's the best spot for that?
Keywords: relnote
Duplicate of this bug: 672270

Comment 10

6 years ago
Here's a quick explanation of what's going on to make it easier to add a relnote for this:

In bug 474721, we added the ability for the message pane to prefer the message header display name; when I did this, I set contacts to default to preferring the address book display name, since that's how 3.x worked.

In bug 243631, we added the ability for the message pane to use the address book display name; the behavior for this is the same as the message header, except that the thread pane doesn't use the "You" shorthand that the message pane does.

As a result, in 5.0, address book entries from previous versions will always use the display name from the address book, everywhere. In previous versions, they'd show the address book name in the message pane, but the message header name in the thread pane. To switch to preferring the message header display name, you need to edit the contact and deselect "Always prefer display name over message header".

Finally, it's possible to customize how the display name works in the message pane by overriding the Javascript function FormatDisplayName. That doesn't work for the thread pane though, since it's a different function, but I believe it's possible to override in a different way.

Comment 11

6 years ago
> In bug 243631, we added the ability for the message pane to use the address book display 

This should be "the thread pane", not "the message pane".

Updated

6 years ago
Duplicate of this bug: 673671

Comment 13

6 years ago
I'm confirming this, since it's a fairly common issue, though the "fix" here is really just improving our documentation. Until that happens, here's a quick summary of how to fix this issue if you encounter it. There are two ways to do it:

1) Use the display name from the message header for everyone

   Go to Tools -> Options (or Edit -> Preferences), then go to Advanced ->
   Reading & Display and uncheck "Show only display name for people in my
   address book".

2) Use the display name from the message header for certain contacts

   In the message pane, click on the star next to the contact you want to
   modify, then click "Edit Details" and uncheck "Always prefer display name
   over message header".
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [see comment 13 for how to fix this]

Updated

6 years ago
Duplicate of this bug: 674563
Doesn't sound like we need to relnote this?

Comment 16

6 years ago
Maybe relnote is the wrong word, but I think there should be some sort of info on this in an easy-to-find place where people would go when asking for support (I'm not really sure where this would be).
Roland, Jen, can we make sure we've got something on sumomo for this please?
Assignee: nobody → jenzed
Whiteboard: [see comment 13 for how to fix this] → [see comment 13 for how to fix this][document comment 13 in sumomo ]
assigned this to jen to document on SuMoMo
Status: NEW → ASSIGNED
(Assignee)

Comment 19

6 years ago
I've created a new article to explain this: https://support.mozillamessaging.com/en-US/kb/display-name-message-list-and-message-pane. I've also added the issue to the "New in Thunderbird 5" page.

Jim, would you please read the article over and confirm that it is correct?

Comment 20

6 years ago
I believe this paragraph is inaccurate: "However, in the message display, the name specified in the message header is always displayed, which means that the display name in the message display may be different from the name in the message list."

The display name should always be the same in the message list and message display, except when the contact in question is one of your identities (then the display name is "You"). If the contact isn't in your address book, the message display will additionally show the email address.

Here's a summary of the behavior. Assume we get an email from "Bob <bob@example.com>":

Old way (3.x)
=============

Not in address book:
  Message list:    Bob
  Message display: Bob <bob@example.com>

In address book as Robert:
  Message list:    Bob
  Message display: Robert

In address book as Robert, "Show only display name for people in my address book" unchecked:
  Message list:    Bob
  Message display: Bob <bob@example.com>

New Way (5.0)
=============

Not in address book:
  Message list:    Bob
  Message display: Bob <bob@example.com>

In address book as Robert, "Always prefer display name over message header" checked:
  Message list:    Robert
  Message display: Robert

In address book as Robert, "Always prefer display name over message header" unchecked:
  Message list:    Bob
  Message display: Bob

In address book as Robert, "Show only display name for people in my address book" unchecked:
  Message list:    Bob
  Message display: Bob <bob@example.com>

Comment 21

6 years ago
yeah, the bug fix that caused the need for this article was to make the message list display the same information as the message display, i.e., both now use the display name if the user has that pref set (previously, only the message display used the display name).

Updated

6 years ago
Duplicate of this bug: 682567
Bug 669925 reported similar issue(same?) in "non-ascii in mail address" case.
xref that bug for ase of tracking and search.
Blocks: 669925

Updated

6 years ago
No longer blocks: 669925

Updated

6 years ago
See Also: → bug 669925
Duplicate of this bug: 686796
Duplicate of this bug: 696934
Removing relnote keyword from bugs that are no longer significant or not needing to be mentioned in the release notes.
Keywords: relnote
You need to log in before you can comment on or make changes to this bug.