Search should list only supported add-ons when appVersion filter is set

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Search
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: krupa, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 547301 [details]
screenshot

Firefox 6.0

steps to reproduce:
1. Load https://addons.allizom.org/z/en-US/firefox/search/es?q=Entwickler-Kommentare 
2. From 'Refine results' select 'Compatible with' to be 6.0
3. Notice the filtered search results.


expected behavior:
Only add-ons which are compatible with 6.0 are listed in the search results.

actual behavior:
'Wordpress Helper' which is not compatible with 6.0 is still listed in the search results
Wouldn't that be nice.

The problem: to find something compatible with 6.0 we need to look for a version with appsupport.min <= 6.0 <= appsupport.max. But if we really use 6.0 then version with appsupport.max = 6.0a1 are never found because 6.0a1 < 6.0. If we wanted to show 6.0a1 in the sidebar then this would be possible.

=> wontfix because the magic only-show-compatible fix will take care of this, somehow.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
Target Milestone: 6.1.7 → 4.x (triaged)
(Reporter)

Comment 2

7 years ago
This is supported in zamboni. Try https://addons.allizom.org/en-us/firefox/search/?lver=6.0&q=fire&y=0&x=0&cat=all in firefox 6.0

We should try to support all the useful features which supported in zamboni.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(In reply to comment #2)
> This is supported in zamboni. Try
> https://addons.allizom.org/en-us/firefox/search/?lver=6.
> 0&q=fire&y=0&x=0&cat=all in firefox 6.0

No it's not. Here is sphinx filtering to 6.0 and showing Wordpress Helper, which is only compatible up to 6.0a1:

https://addons.allizom.org/en-us/firefox/search/?lver=6.0&q=wordpress+helper
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.