Closed Bug 673099 Opened 9 years ago Closed 9 years ago

Back button reverts tab-modal dialogs to window-modal

Categories

(Firefox :: General, defect)

5 Branch
All
Other
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 637160

People

(Reporter: wizard04, Unassigned)

Details

Attachments

(2 files, 1 obsolete file)

Attached file Test case (obsolete) —
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

1) clicked a link that shows an alert onclick
2) tab-modal alert showed; clicked OK; browser opens linked page
3) clicked back button
4) clicked on the link again


Actual results:

window-modal alert showed


Expected results:

alert should still have been tab-modal
Attached file Test case
(submitted as text/html instead of text/plain)
Attachment #547381 - Attachment is obsolete: true
Attachment #547383 - Attachment mime type: text/plain → text/html
Works for me on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110720 Firefox/8.0a1

Can you be more clear on what would be the expected results? Every time I click the link a window -modal alert is showed. Could you attach a screenshot of the issue? Thanks
When I click the link the first time, I get the tab-modal dialog box shown on the left. When I click it the second time, I get the window-modal dialog box shown on the right.
ID:  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0a1) Gecko/20110720 Firefox/8.0a1

> When I click the link the first time, I get the tab-modal dialog box shown
> on the left. When I click it the second time, I get the window-modal dialog
> box shown on the right.

I still can't see a difference in the 2 window instances. I am using Firefox Nightly.
Can you please check to see if the issue is visible on the latest Firefox 6 Beta?
http://www.mozilla.com/en-US/firefox/channel/
It may have been fixed since Fx5. Thanks
This issue is not present on the Firefox 6 Beta (as suggested in Comment 4). So, it will be resolved when Firefox 6 will be launched in August.
Setting this bug as Resolved. If you still experience this on FX 6, feel free to reopen the bug. Thanks.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
This was fixed by bug 637160. I was thinking that landed in 5 (which would have made this quite odd), but it actually didn't land until FF6.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 637160
You need to log in before you can comment on or make changes to this bug.