mailto: link opens new tab, then compose window opens, superfluous new tab stays open

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: tessarakt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2012-03-01])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110713171652

Steps to reproduce:

I received a newsletter (HTML) with an unsubscribe link (which was a mailto:...@...?subject=...&body=... link). I clicked this link.


Actual results:

 A new tab opened with "Loading ..." in the caption. Then a message compose windows opened, with subject and body pre-filled. The tab stayed open, caption was still "Loading...", the tab itself was empty (white background).


Expected results:

The tab should not have opened, or at least it should have been closed when the message compose window opened.
Jens is this a regression ?
(Reporter)

Comment 2

7 years ago
Never seen this before ... I've only seen similar things in Firefox, when a link is opened in a new tab and then Firefox recognises that it needs to download it.

The "link opens tab" is an essential element of this bug - and TB did not have tabs for that long ...

Comment 3

7 years ago
I can't reproduce this, but maybe it's a regression from bug 64267? (Not that I can figure out how...)

Comment 4

6 years ago
Reporter do you still see this problem when using recent version of
Thunderbird?
Whiteboard: [closeme 2012-03-01]
(Reporter)

Comment 5

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #4)
> Reporter do you still see this problem when using recent version of
> Thunderbird?

Nope. mailto: links directly open a compose window, http links open in Firefox ...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 6

5 years ago
Doesn't this bug happen with a mailto link that also has target="_blank"?

Comment 7

4 years ago
Tested on Thunderbird 24.5.0 on Windows 7.

Steps to reproduce:
Open a new HTML composition window, insert the HTML code
    <a href="mailto:test@example.com" target="_blank">mail</a>
and save the message as a draft, open the message in the Drafts folder, and click on the link.

I see a new empty tab titled "Loading..." staying opened.

I can open a new bug for this if necessary.
You need to log in before you can comment on or make changes to this bug.