Firefox 6 Beta On Android UI Corruption

RESOLVED WORKSFORME

Status

Firefox for Android Graveyard
General
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: Tommy He, Unassigned)

Tracking

Firefox 6
All
Other

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 547394 [details]
ff6b-xperianeo.png

User Agent: Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0
Build ID: 20110713171652

Steps to reproduce:

Install Firefox 6 Beta from Android Market and Launch on SE XperiaNeo 2.3.2


Actual results:

UI Corruption from the first launching and afterwards.

The app became not usable at all.

See the attached screenshot. (the red color is due to the known issue of Xperia series handset in screen capture tools.)


Expected results:

No UI corruption and the app could work like stable 5 release
Tommy, do you have extensions installed?
Does this also happen with a clean profile?
tracking-firefox6: --- → ?
Sony Ericsson Xperia Neo MT15 / MT15i (SE Halon) specs indicate that the device has adequate requirements for running Firefox, so this is strange. As Martijn mentioned, please try a new profile.

Settings -> Applications -> Manage Applications -> Firefox Beta -> Clear Data
(Reporter)

Comment 3

7 years ago
No extension was installed.
It is a fresh launch after downloading from Android Market.

After Clear Data and relaunch the program, the same problem still persist.

I know it's very strange especially on the same mobile Firefox 5 stable runs well.
I even tried to remove the Firefox 5 to make sure it won't affect the Beta version, but nothing changed.
(Reporter)

Comment 4

7 years ago
If there's any other infos I can provide, just let me know. I had done a few Android application development work and quite familiar with Android SDK.

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Really strange, it looks almost as if no stylesheets are applied to chrome.
What Android version is your phone running?

I assume you can access urls like chrome://browser/skin/platform.css and chrome://global/skin/ ?

Updated

7 years ago
tracking-fennec: --- → ?
tracking-firefox6: ? → ---
(In reply to comment #4)
> If there's any other infos I can provide, just let me know. I had done a few
> Android application development work and quite familiar with Android SDK.

Any issues if you try a Nightly (more recent code) build from: http://nightly.mozilla.org/mobile.html ?
(Reporter)

Comment 7

7 years ago
(In reply to comment #5)
> Really strange, it looks almost as if no stylesheets are applied to chrome.
> What Android version is your phone running?

2.3.2

> I assume you can access urls like chrome://browser/skin/platform.css and
> chrome://global/skin/ ?

No, I cannot. The widget doesn't respond to click event.

(In reply to comment #6)
> (In reply to comment #4)
> > If there's any other infos I can provide, just let me know. I had done a few
> > Android application development work and quite familiar with Android SDK.
> 
> Any issues if you try a Nightly (more recent code) build from:
> http://nightly.mozilla.org/mobile.html ?

Tried the latest update from Market, the same issue. Will see how it goes with Nightly.
Is it possible for you to attach logcat output? If you have the Android SDK you can use "adb logcat" to get the output. If not, try installing "aLogcat" from the Android Market and use it to capture the output of a Fennec startup.
(Reporter)

Comment 9

7 years ago
(In reply to comment #6)
> (In reply to comment #4)
> > If there's any other infos I can provide, just let me know. I had done a few
> > Android application development work and quite familiar with Android SDK.
> 
> Any issues if you try a Nightly (more recent code) build from:
> http://nightly.mozilla.org/mobile.html ?

The Nightly build works fine, doesn't have issue like this.

(In reply to comment #8)
> Is it possible for you to attach logcat output? If you have the Android SDK
> you can use "adb logcat" to get the output. If not, try installing "aLogcat"
> from the Android Market and use it to capture the output of a Fennec startup.

I'm upgrading my mobile to 2.3.3 to see if there's any change.

Will do call the logcat once finished.
We've had other reports of this problem from Cyanogenmod 7 users.  Tomme He, are you using Cyanogenmod, and if so, which version?
(Reporter)

Comment 11

7 years ago
(In reply to comment #10)
> We've had other reports of this problem from Cyanogenmod 7 users.  Tomme He,
> are you using Cyanogenmod, and if so, which version?

No, the screenshot was captured on a stock SE 2.3.2 ROM.
(Reporter)

Comment 12

7 years ago
Created attachment 549617 [details]
New Screenshot after 2.3.3

It seems to back to work after OTA upgrade to 2.3.3.

I notice that the widget style presented in previous version seems to be replaced by the native Gingerbread style. Not sure if it's a design intension or UI style theme lose.
Yes, that's probably design intention.
I wonder if this is related to bug 676052.
(Reporter)

Comment 15

7 years ago
So may I say that it would cause a regression on Gingerbread below 2.3.3?
sounds like an OS bug, resolving WFM
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.