Closed Bug 673130 Opened 9 years ago Closed 9 years ago

reload broken, errors in console (nsISHistory.getHistoryAtIndex), page missing from sessionstore.js

Categories

(Firefox :: Session Restore, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 669196

People

(Reporter: shaver, Unassigned)

Details

I have a tab that I can't reload, and which doesn't appear in the sessionstore.js.

The error I get when I reload is

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.getEntryAtIndex]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource:///components/nsSessionStore.js :: sss_collectTabData :: line 1653"  data: no]
Source File: resource:///components/nsSessionStore.js
Line: 1653

Reload button is active and cmd-R flashes 

The tab in question has an active back button, but long-pressing it doesn't give me the drop down.

My session restore file is now ~2 hours old, which matches exactly when I loaded the page.  I can send it along privately, I think.

The page is nothing fancy, just a forum (not sure if you'll be able to see it): http://forums.somethingawful.com/showthread.php?threadid=3397539&userid=0&perpage=30&pagenumber=199

I have several tabs open to pages on that forum: they work fine, and are in the ss.js file if I loaded them before the Sessionpocalypse.
This is most excellent in that you've hit a bug we've been seeing on G+ on something not G+. And I can go to that page, (then go to the next page in the thread) and reproduce!

(In reply to comment #0)
> My session restore file is now ~2 hours old, which matches exactly when I
> loaded the page.  I can send it along privately, I think.

I don't think that will help us here.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 669196
You need to log in before you can comment on or make changes to this bug.