A sharp (#) in URL avoid reloading and don't clear forms

RESOLVED DUPLICATE of bug 778399

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 778399
7 years ago
5 years ago

People

(Reporter: DJiK, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Fill a form and press Enter in the URL bar


Actual results:

if URL does not contain a #, the form is cleared, the page is relaoded (at least checked from server),
if URL contains #, nothing happens.
(Reporter)

Comment 1

7 years ago
Nobody cares? :-?

Comment 2

7 years ago
Please provide a public URL or reduced test case that exhibits this issue.
(Reporter)

Comment 3

7 years ago
Just add a # to any URL (for example this page) and press Enter, the page doesn't reload.

Comment 4

7 years ago
I get the same results for this page with and without the #. The page successfully reloads, and the form contents are not cleared (as they should not be - forms are only cleared on a force reload).

Does the issue still occur if you start Firefox in Safe Mode? http://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile? http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile
(Reporter)

Comment 5

7 years ago
> the form contents are not cleared (as they should not be


I think you press F5 to actualise the page, not Enter in the URL bar, which should clear the forms.

The bug was confirmed by several people on a forum (I can't find again where because it's old). Even on a clear profile.

Comment 6

5 years ago
Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Firefox/24.0
Mozilla/5.0 (X11; Linux i686; rv:25.0) Gecko/20100101 Firefox/25.0
Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0


Reproducible on FF 24 beta 1 (Build ID: 20130806170643), latest Nightly (Build ID: 20130811030225) and Aurora (Build ID: 20130812004004): if I add a "#" at the end of an URL and press Enter, nothing happens; but if I press F5 or click the Refresh button, the page reloads.

Is this by design?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Other → All

Updated

5 years ago
Version: 5 Branch → Trunk

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 778399
(Reporter)

Comment 8

5 years ago
This bug is older, so it's not supposed to be marked as duplicate.
The new one is a duplicate.

And it's still NOT CORRECTED!
You need to log in before you can comment on or make changes to this bug.