Closed Bug 673199 Opened 11 years ago Closed 11 years ago

Gecko Alert "java.net.MalformedURLException: Protocol not found:" after getting an update notification that a build is available

Categories

(Firefox for Android Graveyard :: General, defect, P4)

ARM
Android
defect

Tracking

(Not tracked)

VERIFIED FIXED
Firefox 8

People

(Reporter: nhirata, Assigned: alexp)

References

Details

Attachments

(1 file)

Mozilla/5.0 (Android; Linux armv71; rv8.0a1) Gecko/20110718 Firefox/8.0a1 Fennec/8.0a1
Device: Thunderbolt
OS: Android 2.2

1. download the 7/18/2011 build of fennec
2. go to about:fennec
3. setup logcat for device
4. select the button for checking for an update
5. check logcat

Expected: no Gecko Alert
Actual:

07-21 12:04:17.690: INFO/GeckoAppJava(3724): GeckoAppShell.showAlertNotification
07-21 12:04:17.690: INFO/GeckoAppJava(3724): - image = ''
07-21 12:04:17.690: INFO/GeckoAppJava(3724): - title = 'Nightly 8.0a1 available'
07-21 12:04:17.690: INFO/GeckoAppJava(3724): - text = 'Download & Install…'
07-21 12:04:17.690: INFO/GeckoAppJava(3724): - cookie = ''
07-21 12:04:17.690: INFO/GeckoAppJava(3724): - name = 'update-app'
07-21 12:04:17.770: ERROR/GeckoAlert(3724): failed to create bitmap
07-21 12:04:17.770: ERROR/GeckoAlert(3724): java.net.MalformedURLException: Protocol not found: 
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at java.net.URL.<init>(URL.java:275)
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at java.net.URL.<init>(URL.java:159)
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at org.mozilla.gecko.AlertNotification.setCustomIcon(AlertNotification.java:94)
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at org.mozilla.gecko.GeckoAppShell.showAlertNotification(GeckoAppShell.java:906)
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:395)
07-21 12:04:17.770: ERROR/GeckoAlert(3724):     at org.mozilla.gecko.GeckoApp$2.run(GeckoApp.java:170)
07-21 12:04:17.780: INFO/GeckoAppJava(3724): Created notification ID -297100515
Summary: Gecko Alert → Gecko Alert "java.net.MalformedURLException: Protocol not found:" after getting an update notification that a build is available
OS: Mac OS X → Android
Hardware: x86 → ARM
I believe this is just a logged exception that's thrown from within a try/catch block block, so it's probably not a big deal. I suppose we could just return early in the case of an empty string for the image URL.
Naoki - Since this error occurred in a broken build of Fennec, could you double check that this still happens in a known good previous build (like 7/18) updating to another known good build (like 7/22) ?
Occurs still from 7/24 build to 7/25 build.
Priority: -- → P4
Alex - Can you see if we can avoid the spew?
Assignee: nobody → alexp
Attached patch FixSplinter Review
- Added a check for an empty icon URI
- Removed unused class member variable
Attachment #548356 - Flags: review?(blassey.bugs)
Duplicate of this bug: 673201
Attachment #548356 - Flags: review?(blassey.bugs) → review+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/00dcd122f9a7
Status: NEW → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 8
Verified Fixed
Mozilla/5.0 (Android; Linux armv7l; rv:8.0a1) Gecko/20110728 Firefox/8.0a1 Fennec/8.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.