Closed Bug 673348 Opened 13 years ago Closed 13 years ago

[10.7] Full Screen in Lion freezes/renders computer unusable

Categories

(Firefox :: General, defect)

5 Branch
All
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: steve.g.kelly, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

I went into full screen mode (View>Full Screen) on my Macbook Air running 10.7 Lion, and after a bit of regular use, most of my controls for the computer became nonresponsive except for the mouse. The first time I had to hard power off the machine as nothing would get me out of it (closing the lid didn't even sleep the machine). The second time I was able to get out via sleeping/unsleeping and cmd tabbing out.


Actual results:

Full Screen mode glitched out, causing me to hard reset the computer and/or sleep the machine till i was able to cmd tab out and quit.


Expected results:

Full screen should have just worked without utterly failing
OS: Other → Mac OS X
Summary: Full Screen in Lion freezes/renders computer unusable → [10.7] Full Screen in Lion freezes/renders computer unusable
Could not reproduce this on 10.7 using 

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

(also not using the latest nightly)


Steve, is there a specific website triggering the freeze (maybe something using WebGL or a specific plugin)? Also, could you try again with addons disabled (if you had any enabled the last time)?
WFM on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0a1) Gecko/20110725 Firefox/8.0a1

Can you try this on a new profile:
http://support.mozilla.com/en-US/kb/Managing-profiles
Considering comment1 and comment2, setting resolution to Resolved WFM.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
I have the same issue. Some notes:

- it has been happening since Snow Leopard and still happens on Lion
- it has nothing to do with Flash
- freezes usually occur when switching from fullscreen (Cmd-Shift-F) FF to any other app with Cmd-Tab
- I'm using Vimperator
- It has been happening since FF6 or even earlier (I have 8.0.1 right now)
- new profile suffers as well
Also:

- it doesn't depend on any specific website
- it does seem to depend on different on-screen overlays. Like, disabling Growl has helped to reduce number of freezes drastically. Still, they seem to happen mostly when Cmd-Tab displays applications list or when I switch workspaces (desktops in mac)
You need to log in before you can comment on or make changes to this bug.