Tabs resizing without cursor leaves the tab bar, when a moved tab closes

REOPENED
Unassigned

Status

()

Firefox
Tabbed Browser
REOPENED
7 years ago
2 years ago

People

(Reporter: fredy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When you move a tab at the tab bar and then you close it, the rest tabs resize.

Reproducible: Always at the latest 5 to 8 64bit linux builds of firefox.

Steps to Reproduce:
0. The cursor should remain on the tab bar at all of the rest steps.
1. Open several tabs until the size of them to be smaller (e.g. 3/4 of the initial size).
2. Move one of these tabs.
3. Close the moved tab.

Actual Results:  
The rest tabs resize without having moved the cursor out of the tab bar.

Expected Results:  
The rest tabs should not resize until you move the cursor out of the tab bar.

Extra Information:
1. This is not happening at the panorama. When you move one tab at the panorama and close it there, the rest tabs don't resize. However if you return from panorama to tab bar and close the panorama's moved tab then you have the reported results.
2. This bug is not affected by the number of tabs that are moved.
3. This bug happens to all of the moved tabs.
4. This bug happens to the moved tab, even if you return the tab at its initial position.
5. This bug is not affected by the focus state of tab. It still happens, if you focus at another tab and then you focus or not back at the moved tab.
6. If the size of the tabs is too small, the resize is barely noticeable.

Comment 1

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110724 Firefox/8.0a1

Albeit it is a corner case - this is still an issue. Setting status to New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110728 Firefox/8.0a1

At the above last nightly it seems that the bug is solved.
Should I close this bug or should I leave it open until this bug fix passes to stable version?

Comment 3

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110728 Firefox/8.0a1

With the introduction of the tabbed-animation feature, your issue can no longer be reproduced, becoming thus Invalid. Changing the status accordingly.

Thanks for bug report!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
This bug is back. I tested on Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20100101 Firefox/13.0 and on the latest nightly Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/16.0 Firefox/16.0a1. So I reopen the bug.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 5

2 years ago
I would like to work on this bug. Can it be assigned to me please.

Comment 6

2 years ago
Created attachment 8826140 [details] [diff] [review]
one possible solution for bug

In this solution, I considered the only case when tab container is not overflowed. Because if the container is overflowed then I think the present behavior is what desired. Though if wanted then changes can be made for all cases.
Attachment #8826140 - Flags: ui-review?(ux-review)
Attachment #8826140 - Flags: ui-review?(mverdi)
Attachment #8826140 - Flags: review?(dao+bmo)
Comment on attachment 8826140 [details] [diff] [review]
one possible solution for bug

I don't understand this patch. It seems backwards. Comment 0 says "the rest tabs should *not* resize until you move the cursor out of the tab bar." As far as I can tell this is our current behavior.
Attachment #8826140 - Flags: review?(dao+bmo)
You need to log in before you can comment on or make changes to this bug.