-moz-transition-delay units are required even when value is zero

RESOLVED DUPLICATE of bug 653999

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 653999
7 years ago
7 years ago

People

(Reporter: Rob Crowther, Unassigned)

Tracking

8 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
If you specify this property in your stylesheet:

    -moz-transition-delay: 0, 10s;

Firefox logs an error 'Error in parsing value for '-moz-transition-delay'.  Declaration dropped.'  To get it to work you need to add the units to the zero value:

    -moz-transition-delay: 0s, 10s;

This is unlike any other browser's implementation of -*-transition-delay and also unlike other CSS rules where the units can be dropped if the value is zero.

Comment 1

7 years ago
The rule that the unit is optional only for zero lengths.
See http://www.w3.org/TR/css3-values/#values

Comment 2

7 years ago
Let's dup this against a very similar bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 653999
You need to log in before you can comment on or make changes to this bug.