Last Comment Bug 673556 - We use UINT32_MAX in c++ but don't define __STDC_LIMIT_MACROS
: We use UINT32_MAX in c++ but don't define __STDC_LIMIT_MACROS
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla8
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
:
Mentors:
Depends on: 674618
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-22 14:31 PDT by Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
Modified: 2011-07-27 11:48 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.35 KB, patch)
2011-07-22 14:36 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
no flags Details | Diff | Splinter Review
Also change the js configure (1009 bytes, patch)
2011-07-26 08:53 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
khuey: review+
Details | Diff | Splinter Review

Description Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-07-22 14:31:27 PDT
The c99 standard says:

C++ implementations should define these macros only when __STDC_LIMIT_MACROS
is defined before <stdint.h> is included

and "these macros" are the limit ones like UINT32_MAX.

Most implementations ignore this, including the stdint.h used by g++-4.2 on OS X 10.5, but /usr/include/stdint.h on OS X 10.5 does require __STDC_LIMIT_MACROS to be defined and therefore our builds on 10.5 with clang fail.
Comment 1 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-07-22 14:36:13 PDT
Created attachment 547807 [details] [diff] [review]
patch
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-26 08:43:03 PDT
Comment on attachment 547807 [details] [diff] [review]
patch

Should we be adding these to js/src's configure too?
Comment 3 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2011-07-26 08:53:28 PDT
Created attachment 548478 [details] [diff] [review]
Also change the js configure

I had missed the js configure since it is a bit different in this area. Thanks for noticing.
Comment 4 :Ehsan Akhgari 2011-07-26 14:10:13 PDT
Pushed to inbound.
Comment 5 Marco Bonardo [::mak] 2011-07-27 03:40:34 PDT
http://hg.mozilla.org/mozilla-central/rev/ba2bdf497934
Comment 6 Jason Orendorff [:jorendorff] 2011-07-27 11:48:26 PDT
This causes warnings when building js/src on Mac. No big deal though. Patching it in bug 674618.

Note You need to log in before you can comment on or make changes to this bug.