Closed Bug 673585 Opened 11 years ago Closed 11 years ago

Unix selection clipboard is broken

Categories

(Core :: Widget: Gtk, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 673315

People

(Reporter: taras.mozilla, Unassigned)

Details

(Keywords: regression)

No description provided.
On Linux, i can no longer select text in Firefox Nightly and paste it with middle click. I can select text in other apps in paste in Firefox, but copying is broken from within Firefox. I believe this started 2 days ago.
Any relation to this error that just popped up a few days ago?

###!!! ABORT: X_CopyArea: BadMatch (invalid parameter attributes); 2 requests ago: file /builds/slave/m-cen-lnx-ntly/build/toolkit/xre/nsX11ErrorHandler.cpp, line 199
(In reply to comment #1)
> I believe this started 2 days ago.

Confirmed that the first bad build is 2011-07-20. Regression pushlog for that nightly:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a666b4f809f0&tochange=19348341366b
Keywords: regression
Hardware: x86 → All
Version: unspecified → Trunk
On mozilla-inbound, the regression started in today's nightly -- that yields this regression pushlog for that branch:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e2c917e0bc31&tochange=eac851d9d505

and this subset of that (a merge from m-c) intersects with the m-c pushlog from comment 3:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=8670ac4f18b1

In that range, bug 671319 looks most suspicious.  Tentatively flagging as regression from that.
Blocks: 671319
(In reply to comment #4)
> In that range, bug 671319 looks most suspicious.

ah, and that's already got a version of this (bug 673315) marked as a regression.

Duping.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 673315
You need to log in before you can comment on or make changes to this bug.