firefox-bin process - High CPU usage on Mac OS X Lion

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Peter Biely, Unassigned)

Tracking

5 Branch
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7) AppleWebKit/534.48.3 (KHTML, like Gecko) Version/5.1 Safari/534.48.3

Steps to reproduce:

Simple internet browsing, not many tabs opened (even one causes the problem).


Actual results:

When I run Firefox browser on Mac OS X Lion 10.7 GM it uses much more cpu, compared to Safari or compared to the the same browser but previous system (10.6.8). - I have dual boot on my machine 
It heats cpu more than on Mac OS X 10.6.8 Snow Leopard. My MacBook (late 2008 unibody with 4GB RAM) fans are noisier and CPU is much more overloaded than browsing same pages on the older system. I've tried also Firefox 6.0 beta - same result.

Updated

6 years ago
Duplicate of this bug: 673683

Updated

6 years ago
Duplicate of this bug: 673686

Updated

6 years ago
Duplicate of this bug: 673687
You are going to have to give some numbers. Like, how much CPU compared to snow leopard. Also, have you tried a fresh profile? http://support.mozilla.com/kb/Managing+profiles
(Reporter)

Comment 5

6 years ago
On Snow Leopard: CPU utilization with simple 3 non flash pages is 5-10%, On Lion is about 80-113% (when using flash (11beta) it's even more). Same web on Safari on Lion takes no more than 13% of CPU.
First I was thinking that such overload is due the Spotlight indexing, but the next day when cooler fan was running too noisy, I've checked it via activity manager and top.
(Reporter)

Comment 6

6 years ago
Combination of cleaning profile and Firefox 6.0b2 resolved the problem with overload. But still I don't get it why 5.0.1 takes more cpu. 6.0 b2 seems working fine - this "workaround" is so far so good for me.
(Reporter)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.