RSS - name of the author is not displayed

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: MikkCZ, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747



Actual results:

When the author of an item is in the source entered like this: "<name@domain.tld>" (without display name), nothing is shown in the space for author.

(probably the same issue concerns TB)


Expected results:

When there is no display name, at least the e-mail address should be displayed, like when the author is entered like this: "name@domain.tld" = without <>.

Comment 2

7 years ago
Is this in the mailnews RSS reader or the browser feed preview display?
In the mailnews RSS reader list.
When displaying the concrete item, there is "<name@domain.tld>". But in the list is nothing.

Comment 4

7 years ago
The blog reader code is shared with Thunderbird. Moving to MailNews Core.
Component: Feed Discovery and Preview → Feed Reader
OS: Other → All
Product: SeaMonkey → MailNews Core
QA Contact: feed.handling → feed.reader
Version: unspecified → 5.0

Comment 5

5 years ago
first, there cannot be <> in a non cdata <author> tag.  but when entered in a cdata this works for me; <name@domain.tld> is shown in the threadpane list, while the name without <> is shown in the header From, both correctly.  TB24.

reopen with a specific testcase if still a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.