Crash when forwarding S/MIME encrypted message [crash @mime_find_class ]

RESOLVED DUPLICATE of bug 658862

Status

defect
--
critical
RESOLVED DUPLICATE of bug 658862
8 years ago
8 years ago

People

(Reporter: patrick, Unassigned)

Tracking

SeaMonkey 2.2 Branch
x86
macOS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
See crash ID 1b16a1d1-3e86-4778-ae0a-7a1412110724.

Bugs 658862 and 658793 still occur on SeaMonkey 2.2.

NB: The reason for this bug also prevents Enigmail from decrypting PGP/MIME messages with SeaMonkey 2.2.

Stack:
0 	XUL 	mime_find_class 	mailnews/mime/src/mimei.cpp:754
1 	XUL 	mime_crypto_object_p 	mailnews/mime/src/mimei.cpp:1194
2 	XUL 	MimeMessage_parse_line 	mailnews/mime/src/mimemsg.cpp:399
3 	XUL 	mime_LineBuffer 	mailnews/mime/src/mimebuf.cpp:184
4 	XUL 	MimeObject_parse_buffer 	mailnews/mime/src/mimeobj.cpp:275
5 	XUL 	mime_display_stream_write 	mailnews/mime/src/mimemoz2.cpp:991
6 	XUL 	nsStreamConverter::OnDataAvailable 	mailnews/mime/src/nsStreamConverter.cpp:979
7 	XUL 	nsMailboxProtocol::ReadMessageResponse 	mailnews/local/src/nsMailboxProtocol.cpp:586
8 	XUL 	nsMailboxProtocol::ProcessProtocolState 	mailnews/local/src/nsMailboxProtocol.cpp:683
9 	XUL 	nsMsgProtocol::OnDataAvailable 	mailnews/base/util/nsMsgProtocol.cpp:387
10 	XUL 	nsInputStreamPump::OnStateTransfer 	netwerk/base/src/nsInputStreamPump.cpp:510
11 	XUL 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:400
12 	XUL 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
13 	XUL 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:618
14 	XUL 	NS_ProcessPendingEvents_P 	nsThreadUtils.cpp:200
15 	XUL 	nsBaseAppShell::NativeEventCallback 	widget/src/xpwidgets/nsBaseAppShell.cpp:130
16 	XUL 	nsAppShell::ProcessGeckoEvents 	widget/src/cocoa/nsAppShell.mm:399
17 	CoreFoundation 	CoreFoundation@0x4e400 	
18 	CoreFoundation 	CoreFoundation@0x4c5f8 	
19 	libSystem.B.dylib 	libSystem.B.dylib@0x4d1f 	
20 	libSystem.B.dylib 	libSystem.B.dylib@0x4989 	
21 	XUL 	nsGenericElement::AddRef 	
22 	XUL 	nsPresContext::Release 	
23 	XUL 	nsDOMEvent::DuplicatePrivateData 	
24 	XUL 	nsDOMUIEvent::DuplicatePrivateData 	content/events/src/nsDOMUIEvent.cpp:388
25 	XUL 	nsEventDispatcher::Dispatch 	
26 		@0x7fff707df62f 	
27 	CoreFoundation 	CoreFoundation@0x1b20f 	
28 	GeForceGLDriver 	GeForceGLDriver@0x0 	
29 	XUL 	nsSystemPrincipal::Release 	caps/src/nsSystemPrincipal.cpp:75

Comment 1

8 years ago
This should be fixed in SeaMonkey 2.3beta1
For SeaMonkey 2.2 please see Bug 243833 Comment 127
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658862

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.