Port bug 552864 - Throw away wrapper shell script on unix and lazily load libxul

RESOLVED DUPLICATE of bug 668869

Status

defect
RESOLVED DUPLICATE of bug 668869
8 years ago
7 years ago

People

(Reporter: standard8, Assigned: Bienvenu)

Tracking

Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird7-)

Details

+++ This bug was initially created as a clone of Bug #552864 +++

We need to port the work in bug 552864 to Thunderbird. There are some reasons for this:

1) DLL Blocklisting is broken until we do at least part of the port (not good).

2) There should be significant start-up performance improvements, especially when combined with bug 632404.

tracking+ for 7 because we need this due to the DLL blocklisting issue.

To fix this we need to port the browser/ parts of:

http://hg.mozilla.org/mozilla-central/rev/8ae2a073b044
http://hg.mozilla.org/mozilla-central/rev/c4bbac1f178b
(In reply to comment #0)
> 1) DLL Blocklisting is broken until we do at least part of the port (not
> good).

I'd interested to know what broke, because the intent was to *not* break the current uses.
Also, bug 658847 should help, here.
Mike is right, the DLL blocklist isn't broken as I thought it was (I'd missed how the change was done). We can just pick this up when we're ready.
Assignee: nobody → dbienvenu
Dependent/Duplicate of bug 668869?
Yeah, this was fixed in bug 668869
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 668869
You need to log in before you can comment on or make changes to this bug.