Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Thunderbird Mac 64 bit builders failing to run buildsymbols

RESOLVED FIXED in mozilla8

Status

()

Core
Build Config
--
blocker
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: standard8, Assigned: khuey)

Tracking

({regression})

Trunk
mozilla8
x86_64
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 548199 [details]
Failure log

Since bug 585015 landed, our 10.6/64 bit Mac builders have been failing to run make buildsymbols - see the attached log.

Note that the 10.5/32 bit Mac builders are running it fine.

From what I can tell, symbolstore.py is attempting to run hg in a new process (using popen), but the pythonpath for that process is incorrect, so hg can't find its libraries that it needs to work.

Given that this seems to be working elsewhere (e.g. SeaMonkey, Firefox builders, 32 bit builders), I'm guessing this is a configuration error in the builder somewhere.
Yeah, so, the patch in bug 585015 sets PYTHONPATH, which is how you add things to sys.path. Presumably your builders have a non-empty PYTHONPATH that we're overwriting. We need to change the variable name.
Assignee: nobody → khuey
Component: Release Engineering → Build Config
Product: Mozilla Messaging → Core
QA Contact: release → build-config
Version: other → Trunk
Created attachment 548204 [details] [diff] [review]
Doh!
Attachment #548204 - Flags: review?(ted.mielczarek)
Attachment #548204 - Flags: review?(ted.mielczarek) → review+
http://hg.mozilla.org/mozilla-central/rev/157a6ba83e8f
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla8
You need to log in before you can comment on or make changes to this bug.