Last Comment Bug 673940 - Thunderbird Mac 64 bit builders failing to run buildsymbols
: Thunderbird Mac 64 bit builders failing to run buildsymbols
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Mac OS X
: -- blocker (vote)
: mozilla8
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
Mentors:
Depends on:
Blocks: 585015
  Show dependency treegraph
 
Reported: 2011-07-25 09:04 PDT by Mark Banner (:standard8)
Modified: 2011-07-25 10:21 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Failure log (6.52 KB, text/plain)
2011-07-25 09:04 PDT, Mark Banner (:standard8)
no flags Details
Doh! (2.91 KB, patch)
2011-07-25 09:42 PDT, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
ted: review+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2011-07-25 09:04:26 PDT
Created attachment 548199 [details]
Failure log

Since bug 585015 landed, our 10.6/64 bit Mac builders have been failing to run make buildsymbols - see the attached log.

Note that the 10.5/32 bit Mac builders are running it fine.

From what I can tell, symbolstore.py is attempting to run hg in a new process (using popen), but the pythonpath for that process is incorrect, so hg can't find its libraries that it needs to work.

Given that this seems to be working elsewhere (e.g. SeaMonkey, Firefox builders, 32 bit builders), I'm guessing this is a configuration error in the builder somewhere.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-07-25 09:30:11 PDT
Yeah, so, the patch in bug 585015 sets PYTHONPATH, which is how you add things to sys.path. Presumably your builders have a non-empty PYTHONPATH that we're overwriting. We need to change the variable name.
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-25 09:42:21 PDT
Created attachment 548204 [details] [diff] [review]
Doh!
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-07-25 10:21:42 PDT
http://hg.mozilla.org/mozilla-central/rev/157a6ba83e8f

Note You need to log in before you can comment on or make changes to this bug.