Closed Bug 673944 Opened 8 years ago Closed 3 months ago

When KB articles are moved, kbforum thread URLs should update

Categories

(support.mozilla.org :: Knowledge Base Software, task, P5)

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: jsocol, Unassigned)

References

Details

(Keywords: good-first-bug, Whiteboard: u=contributor c=wiki p= s=2013.backlog [feature-request])

Like bug 673167 for the forums app, if I go to /kb/foo/discuss/1234, and 1234 is a discussion on bar, not foo, redirect to /kb/bar/discuss/1234.
Target Milestone: 2011Q3 → 2011Q4
Cleaning up 2011Q4
Target Milestone: 2011Q4 → ---
(In reply to Alice Wyman from comment #1)
> Related discussion: 
>  
> https://support.mozilla.com/en-US/kb/make-firefox-remember-usernames-and-passwords/discuss/1637

Since the article for that discussion thread has since moved, that link is now a "page not found ... 
...which is a good example of what this bug is about!

The related discussion thread is now here:

https://support.mozilla.org/en-US/kb/password-manager-remember-delete-change-passwords/discuss/1637

I found it by going to https://support.mozilla.org/en-US/kb/make-firefox-remember-usernames-and-passwords/discuss (which is now empty), then going to the "Article" link to get the new url and adding /discuss/1637 to the end.
Duplicate of this bug: 971938
Priority: -- → P4
Whiteboard: u=contributor c=wiki p= s=2013.backlog
Target Milestone: --- → Future
NI Joni & Madalina
Is any Admin tracking this, and if so where is it listed?
AFAIK the whiteboard tracking is obsolete and sumo bugs only progress if a Champion manages to track them and make a case for them.
Flags: needinfo?(mana)
Flags: needinfo?(jsavage)
I thought this was fixed a while ago. Just added this to the Prioritized backlog spreadsheet.
Flags: needinfo?(jsavage)
Flags: needinfo?(mana)
(In reply to Joni Savage ("need info" me) from comment #6)
> I thought this was fixed a while ago. Just added this to the Prioritized
> backlog spreadsheet.

Still broken.
(In reply to Alice Wyman from comment #3)
> (In reply to Alice Wyman from comment #1)
> > Related discussion: 
> >  
> > https://support.mozilla.com/en-US/kb/make-firefox-remember-usernames-and-passwords/discuss/1637
> 
> Since the article for that discussion thread has since moved, that link is
> now a "page not found ... 
> ...which is a good example of what this bug is about!
> 
> The related discussion thread is now here:
> 
> https://support.mozilla.org/en-US/kb/password-manager-remember-delete-change-passwords/discuss/1637
> 
That article title was renamed yet again so the kbforum thread is again a "page not found".  The moved thread is now here: 
https://support.mozilla.org/en-US/kb/password-manager-remember-delete-change-and-import/discuss/1637
we have bigger fish to fry :-), setting to p5
Keywords: good-first-bug
Priority: P4 → P5
Whiteboard: u=contributor c=wiki p= s=2013.backlog → u=contributor c=wiki p= s=2013.backlog [feature-request]
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.