Add-ons Manager crashes when selecting "Get Add-ons"

RESOLVED WORKSFORME

Status

()

Core
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Ulrich Mayring, Unassigned)

Tracking

({crash})

5 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:2.0.1) Gecko/20110608 Firefox/4.0.1 SeaMonkey/2.1
Build ID: 20110608020727

Steps to reproduce:

I selected "Tools / Add-ons"


Actual results:

The usual Add-ons Manager appears with the tab "Get Add-ons..." selected. In the main window various Add-ons are loading their previews and then the entire screen starts to flash wildly and after a while mouse and keyboard freeze. The entire KDE session crashes and I have to restart the X server afterwards.

I already did a clean re-install of Firefox, started it in safe mode, manually disabled all extensions and plugins, created a new profile - the usual procedure. The problem would not go away. It only happens with Firefox 5, a parallel installation of Firefox 3.6.19 works fine. But it is worth noting that Firefox 3.6.19 doesn't have this preview functionality in the Add-ons manager.


Expected results:

It should not have crashed, but retained its normal functionality of getting and installing Add-ons.
(Reporter)

Updated

7 years ago
OS: Other → Linux
(Reporter)

Updated

7 years ago
Hardware: All → x86

Comment 1

7 years ago
Please provide a crash id or stacktrace -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Keywords: crash
(Reporter)

Comment 2

7 years ago
I am sorry, but I can't, since Firefox freezes the entire KDE and the Mozilla Crash Reporter never comes up. In fact, when I log in from the console after such a crash I can still see the Firefox process running. When I kill it then KDE sometimes comes back and I can continue working (albeit with some UI glitches). In other cases I have to restart KDE.

I reproduced this problem with SeaMonkey 2.2, whereas it doesn't occur with SeaMonkey 2.1 - just in case that helps you track down the exact version of the engine, where the change was introduced.

Comment 3

7 years ago
Mozilla/5.0 (X11; Linux i686; rv:8.0a1) Gecko/20110725 Firefox/8.0a1

Is this happening ever since you've installed Fx 5 on your Linux distribution or has it started happening lately? I am asking this because there might be an addon causing this.

Try a new, empty profile and see whether you can still reproduce the problem:
http://support.mozilla.com/en-US/kb/Managing-profiles

Also, try starting Fx from the terminal and see what erros/warning appear there once you try to enter the Addon Manager.

Thanks!
(Reporter)

Comment 4

7 years ago
Started Firefox with a new, empty Profile. Reproduced the bug. No message in the terminal whatsoever.

This error has only recently appeared, perhaps 3 or 4 days ago. I used Firefox 5 / SeaMonkey 2.2 before without any problems. However, I have already deleted all Add-ons and plugins. The error happens when the Add-ons previews are loading.

Updated

7 years ago
Component: General → General
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 5

7 years ago
I'll attach a screenshot showing what happens in SeaMonkey 2.1 (and presumably Firefox 4, but I can't find any downloads of that version, so I cannot check): when I select "Get Addons", then the previews load and as soon as I start to click or scroll, the screen becomes garbled as seen in the screenshot.

At this point SeaMonkey 2.2 and FireFox 5.0.1 crash as described above. The slightly earlier version only have the UI glitches, but remain operational.

FireFox 3 is perfectly ok, but it doesn't have those Add-on previews anyway.
(Reporter)

Comment 6

7 years ago
Created attachment 548714 [details]
ScreenShot showing UI glitches

Comment 7

7 years ago
Please post the graphics section from about:support
(Reporter)

Comment 8

7 years ago
The Graphics section has only one entry:
GPU Accelerated Windows0/3

Is that sufficient? I can also post a screenshot if needed.

Comment 9

7 years ago
Please attach the full contents from about:support as a text attachment to this report
(Reporter)

Comment 10

7 years ago
Sorry, made a mistake yesterday and posted the output of SeaMonkey 2.1, which is an older version. I now did the same thing for Firefox 6.0 and in the graphics section it said something to the tune of "please update your NVIDIA drivers". Which I promptly did and now the problem has vanished. I can still post the "about:support" output, if it may be useful for further investigation, but I guess I'd have to install the old NVIDIA drivers first in order to reproduce the problem. If that is useful, I'll do it, otherwise the issue can be close. Many thanks.

Comment 11

7 years ago
Glad the driver update worked for you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.