can't collapse+expand accounts in folder pane, tree is undefined

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Bienvenu, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
+++ This bug was initially created as a clone of Bug #658534 +++

tbird trunk circa 2011-05

expected: account folders expanded

result: Error: uncaught exception: [Exception... "'[JavaScript Error: "tree is undefined" {file: "chrome://messenger/content/folderPane.js" line: 889}]' when calling method: [nsITreeView::toggleOpenState]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/bindings/tree.xml :: changeOpenState :: line 241"  data: yes]

As you can see in the patch for bug 658534, explicitly passing in "this" to our nested function fixes the issue, but my understanding is that the original code should have kept working. Apologies if that's not the case.
Whiteboard: js-triage-needed

Comment 1

7 years ago
We have some users in Ubuntu hit this too, and they confirm the observation in https://bugzilla.mozilla.org/show_bug.cgi?id=658534#c13 regarding the problem going away after deleting the startup cache. Running thunderbird with -purgecaches seems to prevent the problem from occurring entirely
I have the same issue with 6.0b1. This makes TB6 highly unusable for me currently.
Keywords: regressionwindow-wanted
Wolfgang, does purging the caches fix this for you?
Hmm, sorry, I had 6.0b2 already installed which has the mentioned workaround.
(Reporter)

Comment 5

7 years ago
(In reply to Wolfgang Rosenauer [:wolfiR] from comment #4)
> Hmm, sorry, I had 6.0b2 already installed which has the mentioned workaround.

Does this mean you can't reproduce the issue with b2?
It hasn't happened for me since 6.0b2 and that is how I understood bug 658534
(Reporter)

Comment 7

7 years ago
(In reply to Wolfgang Rosenauer [:wolfiR] from comment #6)
> It hasn't happened for me since 6.0b2 and that is how I understood bug 658534

great, thanks, just making sure.
(Assignee)

Updated

4 years ago
Assignee: general → nobody
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
Whiteboard: js-triage-needed
You need to log in before you can comment on or make changes to this bug.