Consider porting bug 452915 to our html5elements.css

RESOLVED WONTFIX

Status

Camino Graveyard
General
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: philippe (part-time), Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Bug 452915 removed the 2px border on images that are (also) links.
I've seen it now on a couple of sites that optimise their stylesheets based on Fx 4 or up. Example:
http://www.macupdate.com/app/mac/39580/mac-os-x-10.6.8-supplemental-update
Look at the block around: 'Suggest more similar software' (the Go button,or the 2 arrows to the left of it)

This does the deed:
*|*:-moz-any-link img, img[usemap], object[usemap] {
  border: none;
}
(Reporter)

Updated

6 years ago
Flags: camino2.1?
(Reporter)

Comment 1

6 years ago
[1:30pm] phiw: sauron: do you have any opinion on bug 674122 ? 
[1:31pm] sauron: i think it's terrible for a11y 
[1:32pm] phiw: Yeah, I don't like that change either. I am / was only worried about sites that previously showed no borders because suppressed them
[1:32pm] sauron: and it would annoy me, and make it harder to override places where they're useful
[1:33pm] sauron: my feeling right now is to kick it to 2.1.x; see if it starts to crop up/get complaints
So far this doesn't seem to have come up, and I really haven't seen it outside those buttons on MacUpdate and an "ad" on imagebam.

If Stuart has a strong opinion one way or another, we can go with that, but otherwise I'd prefer to leave it out for the reasons mentioned in comment 1 ;)
Flags: camino2.1? → camino2.1-
(Reporter)

Comment 3

6 years ago
Fwiw, I don't mind WONTFIXING this.

Comment 4

6 years ago
I'd lean toward doing it since everyone else does, but no strong feelings.
When we start seeing significant real-world breakage from this, by all means we should do it.

But right now, a couple of random borders around images where some authors don't expect them doesn't compare to rendering new block elements inline, and fixing this bug would negatively impact accessibility (and make it hard for users override it only in cases where it is useful), and Stuart isn't strongly committed, so WONTFIX at this time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.