Closed Bug 674228 Opened 9 years ago Closed 9 years ago

enable tegra unittests and talos on remaining project branches

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bear, Assigned: bear)

Details

(Whiteboard: [android][tegra])

Attachments

(2 files, 5 obsolete files)

enable for the following:

accessibility
build-system
private-browsing
alder
birch
cedar
holly
larch
maple
Summary: enable unittests and mochitest 1-4 on remaining project branches → enable tegra unittests and talos on remaining project branches
Assignee: nobody → bear
Attachment #548465 - Flags: review?(aki)
Comment on attachment 548465 [details] [diff] [review]
enable unittests and mochitest1-4

>-BRANCHES['addontester']['remote-ts_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-tdhtml_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-tsvg_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-tsspider_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-tpan_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-tp4m_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-tp4m_nochrome_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-twinopen_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>-BRANCHES['addontester']['remote-tzoom_tests'] = (0, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-ts_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-tdhtml_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-tsvg_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-tsspider_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-tpan_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-tp4m_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-tp4m_nochrome_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-twinopen_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)
>+BRANCHES['addontester']['remote-tzoom_tests'] = (1, True, TALOS_REMOTE_FENNEC_OPTS, ANDROID)

I think we said to not touch addontester, correct?

>     'build-system': {
>-        'enable_talos': False,
>+        'talos_suites': {
>+            'remote-ts': 1,
>+            'remote-tdhtml': 1,
>+            'remote-tsvg': 1,
>+            'remote-tsspider': 1,
>+            'remote-tpan': 1,
>+            'remote-tp4m': 1,
>+            'remote-tp4m_nochrome': 1,
>+            'remote-twinopen': 1,
>+            'remote-tzoom': 1,
>+        },

Don't turn on talos without asking branch owners.
Remove this.

>     'private-browsing': {
>-        'enable_talos': False,
>         'enabled_products': ['firefox'],
>         'enable_nightly': False,
>     },

This too.


>-    'alder': {},
>-    'birch': {},
>-    'cedar': {},
>-    'holly': {},
>-    'larch': {},
>+    'alder': { 'talos_suites': {
>+                                'remote-ts': 1,
>+                                'remote-tdhtml': 1,
>+                                'remote-tsvg': 1,
>+                                'remote-tsspider': 1,
>+                                'remote-tpan': 1,
>+                                'remote-tp4m': 1,
>+                                'remote-tp4m_nochrome': 1,
>+                                'remote-twinopen': 1,
>+                                'remote-tzoom': 1,
>+                               },

Are we enabling the entire talos suite list, or only the limited set?

>     # customizations while booked for bcp47 project as per bug 667734
>     'maple': {
>-        'enable_talos': False,

This too.
Attachment #548465 - Flags: review?(aki) → review-
Attachment #548465 - Attachment is obsolete: true
Attachment #548468 - Flags: review?(aki)
Attachment #548468 - Attachment is obsolete: true
Attachment #548468 - Flags: review?(aki)
Attachment #548469 - Flags: review?(aki)
Attachment #548469 - Attachment is obsolete: true
Attachment #548469 - Flags: review?(aki)
Attachment #548476 - Flags: review?(aki)
Comment on attachment 548476 [details] [diff] [review]
enable unittests and mochitest1-4

Can you update the spreadsheet?
Attachment #548476 - Flags: review?(aki) → review+
Comment on attachment 548476 [details] [diff] [review]
enable unittests and mochitest1-4

committed changeset 4490:65a0bcdcc3de
Attachment #548476 - Flags: checked-in+
this doesn't have the change for totalChunks, I was having trouble finding which spot to tweak for this
Attachment #548521 - Flags: feedback?(aki)
Comment on attachment 548476 [details] [diff] [review]
enable unittests and mochitest1-4

This patch is in production now.
this is now running on staging
Attachment #548521 - Attachment is obsolete: true
Attachment #548521 - Flags: feedback?(aki)
Attachment #549112 - Flags: feedback?(jmaher)
Comment on attachment 549112 [details] [diff] [review]
enable more mochitest-plain unittests

Review of attachment 549112 [details] [diff] [review]:
-----------------------------------------------------------------

Simple change.  I would like to profile these for times in the near future so we can see how much extra time per chunk we have.  My concern is when we add more tests, can we stuff them into the [soon to be] existing 8 chunks, or will we need to add more chunks.

I would think the total runtime/chunks needs to be in the 15 minute (900 seconds) time limit.  We should optimize the chunks that are running so we have room for new tests without adding more chunks just because.

r=me with the one change made below

::: mozilla-tests/config.py
@@ +570,5 @@
> +                                       'modules/libjar/test/mochitest',
> +                                       'layout/inspector/tests',
> +                                       'toolkit/xre/test',
> +                                       'toolkit/components/microformats/tests',
> +                                       'MochiKit-142.2/tests',

MochiKit-1.4.2/tests
Attachment #549112 - Flags: feedback?(jmaher) → feedback+
change Harness/sanity to Harness_sanity
Attachment #549112 - Attachment is obsolete: true
Attachment #549381 - Flags: feedback?(jmaher)
Comment on attachment 549381 [details] [diff] [review]
enable more mochitest-plain unittests

Review of attachment 549381 [details] [diff] [review]:
-----------------------------------------------------------------

cool!
Attachment #549381 - Flags: feedback?(jmaher) → feedback+
Comment on attachment 549381 [details] [diff] [review]
enable more mochitest-plain unittests

ready to queue for reconfig
Attachment #549381 - Flags: review?(aki)
Attachment #549381 - Flags: review?(aki) → review+
Comment on attachment 549381 [details] [diff] [review]
enable more mochitest-plain unittests

committed changeset 4510:4930e476fda8
Attachment #549381 - Flags: checked-in+
Whiteboard: [android][tegra]
these changes are now all live
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.