reload of page loads the page in the leftmost tab

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: iconja, Unassigned)

Tracking

5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Reloaded the page in 3dt tab from left. Total 7 tabs open.


Actual results:

The page open in the leftmost tab loaded instead.


Expected results:

Page should have reloaded.

Comment 1

7 years ago
Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode
OS: Other → Windows XP
Hardware: All → x86
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Does the issue still occur if you start Firefox in Safe Mode?
> https://support.mozilla.com/en-US/kb/Safe+Mode

Firstly, it doesn't happen consistently, so it's difficult to check.

In answer to your question: Sort of, as far as i can tell. I just restarted FF in safe mode to check, and one of the recovered tabs loaded the leftmost tab page. 4 other tabs loaded normally. This has happened before during restarts. Sometimes all recovered tabs load the leftmost tab - which is not my home page, just what happened to be in the leftmost tab at the time.

The behavior seems to be a part of a broader issue of tabs "forgetting" their history, including the currently loaded page. I can elaborate if it'll help.
(Reporter)

Comment 3

7 years ago
FF8 reload doesn't work: Press "reload" and the displayed page may load or an unrelated page.

Comment 4

6 years ago
Verified as WFM on:
Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120105 Firefox/12.0a1

Tried this multiple times and the right page reloaded every time.
(Reporter)

Comment 5

6 years ago
I'm not sure why the problem doesn't reproduce. I encounter it every time I restart, and often when I reload. Basically, I never know what I'm going to get. It happens for me on 2 different machines, one with Win XP, the other with Win 7. It started with FF 6, if that's of any help. Also, I have talked to friends who have had the same issue.

Comment 6

6 years ago
(In reply to iconja from comment #5)
> I'm not sure why the problem doesn't reproduce. I encounter it every time I
> restart, and often when I reload. Basically, I never know what I'm going to
> get. It happens for me on 2 different machines, one with Win XP, the other
> with Win 7. It started with FF 6, if that's of any help. Also, I have talked
> to friends who have had the same issue.

Can you please try to reproduce this issue on the latest Firefox the latest Firefox Nightly? You can get the build from ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/

Comment 7

6 years ago
According to the above comments, this issue seems to only reproduce on old Firefox versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

6 years ago
Unfortunately it still happens on my machines. I'm running FF11.0 now. I've played around a bit, and it seems to be related to how long FF has been running or a tab has been open. For example, opening FF, loading a few tabs and restarting works fine. But if I restart FF or reload a tab when back to work after the weekend, all bets are off.

I've learned to live with it, partly by switching to Chrome for some of my frequently used pages, but it's still an issue.

Comment 9

6 years ago
(In reply to iconja from comment #8)
> Unfortunately it still happens on my machines. I'm running FF11.0 now. I've
> played around a bit, and it seems to be related to how long FF has been
> running or a tab has been open. For example, opening FF, loading a few tabs
> and restarting works fine. But if I restart FF or reload a tab when back to
> work after the weekend, all bets are off.
> 
> I've learned to live with it, partly by switching to Chrome for some of my
> frequently used pages, but it's still an issue.

Can you please try to reproduce this issue on the latest Firefox version, starting with a clean profile?
You need to log in before you can comment on or make changes to this bug.