Closed Bug 6744 Opened 21 years ago Closed 21 years ago

profile created has %20 in string rather than a space

Categories

(Core Graveyard :: Profile: BackEnd, defect, P2)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Brade, Assigned: sspitzer)

References

Details

I ran AppRunnerDebug today and was prompted (first time) to create a profile.
For the profile name I entered a string with a space in it:  "Mozilla Brade"
The actual folder created was named "Mozilla%20Brade"

Problems:
 * Difficult to find from the OS
 * Makes name even longer (file system on Mac is already limited to 31
characters)
Status: NEW → ASSIGNED
Target Milestone: M7
Currently all special characters are being escaped.
So only alphabets and numericals can be used. We
will unescape the special characters in M7.
*** Bug 6702 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Target Milestone: M7 → M9
Status: RESOLVED → REOPENED
Reopening.
This is not fixed with my build from this morning.
Resolution: FIXED → ---
*** Bug 7191 has been marked as a duplicate of this bug. ***
Priority: P3 → P2
This bug cause loading mail folders to fail. Bumping priority to P2, cc:ing
putterman and ducarroz.
Adding lchiang to the cc list.  We need this fixed before we can have widespread
mac use, and we should probably put in the dialog some place that you can't
create a profile name with a space in it.
The target milestone shows M9.  I'll add it to the M8 release notes tracking
bug for verah.
Target Milestone: M9 → M10
Changing the target milestone to M10.
*** Bug 12174 has been marked as a duplicate of this bug. ***
Bug 12174 is related in that profiles created before the escaping change can't
be accessed after the change.
Blocks: 12696
Status: REOPENED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
I don't see how this is working, creating a folder with a space in the name
creates a folder with %20 used for space. This does not show in Profile Manager,
but does show in Users50/grace%20bush

(using build 1999092708)
Seth, are you touching this area too?  Looks like we're probably creating the
directory with the encoded name rather than the plain text name.  Should be a
simple fix.
Assignee: gayatrib → sspitzer
Status: REOPENED → NEW
re-assign to me.
Resolution: WORKSFORME → ---
Clearing WORKSFORME resolution due to reopen of this bug.
Target Milestone: M10 → M11
moving to m11.
Status: NEW → ASSIGNED
accepting.  marking all milestone 11.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago21 years ago
Resolution: --- → FIXED
this should be fixed now.

If you created a profile "Foo Bar", it would be "Users50:Foo Bar"

there are a bunch of potential bugs lurking in this code.

1)  what if the profile name is too long for the native file system?  (we need
to hash the name of the directory on disk, if necessary)
2)  what if the profile matches a directory that already exists?
(we need to add a case insensitive check for existance.  FOOBAR and foobar are
the same directory on windows.)
3)  what about special characters?  (can the user ".." or "/" themselves into
trouble?)

marking this fixed, and I'll log the other issues as bugs and fix them.
Status: RESOLVED → VERIFIED
this is fixed in 1999100713 on the mac
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.