Reimaged slaves are stuck on the CHINOOK-ARMEL-2007 target instead of FREMANTLE_ARMEL

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: jhford)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1311710901.1311712883.26292.gz
Maemo 5 QT mozilla-central build on 2011/07/26 13:08:21 
s: linux-ix-slave42

checking for pkg-config... /scratchbox/tools/bin/pkg-config
checking for QtGui QtNetwork QtCore QtOpenGL... Package QtGui was not found in the pkg-config search path. Perhaps you should add the directory containing `QtGui.pc' to the PKG_CONFIG_PATH environment variable No package 'QtGui' found Package QtNetwork was not found in the pkg-config search path. Perhaps you should add the directory containing `QtNetwork.pc' to the PKG_CONFIG_PATH environment variable No package 'QtNetwork' found Package QtCore was not found in the pkg-config search path. Perhaps you should add the directory containing `QtCore.pc' to the PKG_CONFIG_PATH environment variable No package 'QtCore' found Package QtOpenGL was not found in the pkg-config search path. Perhaps you should add the directory containing `QtOpenGL.pc' to the PKG_CONFIG_PATH environment variable No package 'QtOpenGL' found
configure: error: Library requirements (QtGui QtNetwork QtCore QtOpenGL) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
*** Fix above errors and then restart with               "make -f client.mk build"
make[2]: *** [configure] Error 1
make[2]: Leaving directory `/builds/slave/m-cen-lnx-maemo5-qt/build'
make[1]: *** [obj-firefox/Makefile] Error 2
make[1]: Leaving directory `/builds/slave/m-cen-lnx-maemo5-qt/build'
make: *** [build] Error 2
program finished with exit code 2
elapsedTime=12.574411
(If it wasn't clear: all the failures in comment 1 were from linux-ix-slave42.)
The slave has been disabled (in slavealloc and 'buildslave stop') pending investigation of missing Qt libraries.
Assignee: nobody → bhearsum
This is due to the scratchbox on this slave being the wrong target (CHINOOK-ARMEL-2007)
Fixed this slave with "sb-conf select FREMANTLE_ARMEL"
(In reply to comment #5)
> Fixed this slave with "sb-conf select FREMANTLE_ARMEL"

I should note too that sb-conf needs to be run inside of the scratchbox.
Assignee: bhearsum → jhford
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 674458
Reopening to deal with fixing the root of this problem (setting the target as the first build step in a scratchbox build).
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Maemo Qt build failed in configure on linux-ix-slave42: Library requirements (QtGui QtNetwork QtCore QtOpenGL) not met → Reimaged slaves are stuck on the CHINOOK-ARMEL-2007 target instead of FREMANTLE_ARMEL
Created attachment 548790 [details] [diff] [review]
set the target per build

This patch sets the scratchbox target for builds that use Scratchbox.

Verified that this renders down to 

/scratchbox/moz_scratchbox -p -k -d / sb-conf select FREMANTLE_ARMEL

which I ran on a slave manually and verified that it properly changed to the fremantle target.  

not plumbing the setting all the way to config.py because it isn't worth it right now.
Attachment #548790 - Flags: review?(aki)

Updated

7 years ago
Attachment #548790 - Flags: review?(aki) → review+
(In reply to comment #11)
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311792569.
> 1311792688.30646.gz
> s: linux-ix-slave29

(In reply to comment #12)
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1311801750.
> 1311802678.16274.gz
> s: linux-ix-slave23

I'm surprised by these failures, because neither of these have been recently re-imaged. Nonetheless, I fixed them up. I'll be doing a reconfig in a bit to pick up jhford's patch, which should fix this going forward.
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311883760.1311884416.12610.gz
Maemo 5 QT mozilla-inbound build on 2011/07/28 13:09:20
s: linux-ix-slave34
{
configure: error: Library requirements (QtGui QtNetwork QtCore QtOpenGL) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
}

(this is the first reported instance of this on slave34, AFAIK)
(In reply to comment #14)
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311883760.
> 1311884416.12610.gz
> Maemo 5 QT mozilla-inbound build on 2011/07/28 13:09:20
> s: linux-ix-slave34
> {
> configure: error: Library requirements (QtGui QtNetwork QtCore QtOpenGL) not
> met; consider adjusting the PKG_CONFIG_PATH environment variable if your
> libraries are in a nonstandard prefix so pkg-config can find them.
> }
> 
> (this is the first reported instance of this on slave34, AFAIK)

Fixed this one.
John's patch hit production, so we shouldn't see this on any jobs starting after now.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.