Update distribution.ini in the NTT Resonant (greengoo) Partner Repack to remove "goo RSS Reader"

VERIFIED FIXED

Status

VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: kohei, Assigned: cbook)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 548686 [details] [diff] [review]
distribution.ini diff

NTT Resonant has discontinued their own RSS reader service. It has already been removed from the vanilla Firefox builds. (Bug 605653)

The patch for distribution.ini is attached. The browser.contentHandlers.* prefs, which has been set to make the "goo RSS Reader" first, are no longer required.

Please use this for Firefox 6+. Thanks!
(In reply to comment #0)
> NTT Resonant has discontinued their own RSS reader service. It has already
> been removed from the vanilla Firefox builds. (Bug 605653)

Nope, Bug 649888.
Hi Kev, the Firefox 8 release is approaching. Could you take this?
Kev, ping...?
Seems like Kev is busy, so I'll manually edit the ini file and repack the exe/dmg as before, for the meantime.
Attachment #548686 - Flags: review?(kev)

Comment 6

7 years ago
Not so much busy as overwhelmed sometimes by bugmail. All readers are removed by the patch, is this intended behaviour?
Yes, by removing the designation, the order and listing of the feed readers will be the same as the vanilla Firefox.
So I've manually repacked and signed the Firefox 8.0 and 8.0.1 builds.
Please apply my patch to the upcoming Firefox 9 release. Thanks!
Kev: could you review and land my patch when you get a chance?
We are manually repacking and signing the greengoo builds still.

Comment 10

7 years ago
Tomcat: can you take this, please?

Comment 11

7 years ago
(I'm good with the changes, and Tomcat should be able to add this back into the release workflow so you don't have to do it every time).
(Assignee)

Comment 12

7 years ago
yeah will do the changes
(Assignee)

Updated

7 years ago
Assignee: kev → cbook
(Assignee)

Comment 13

7 years ago
Comment on attachment 548686 [details] [diff] [review]
distribution.ini diff

looks good
Attachment #548686 - Flags: review?(kev) → review+
(Assignee)

Comment 14

7 years ago
can we get this into the hg repro ? (don't think i have checkin rights or so - and never did before).

Also Kohei, during the review tests i found also Bug 726948, could you take a look? thanks!
Confirmed: Firefox 10.0.2 was built with the updated distribution.ini. Thank you!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

7 years ago
thanks nick and kohei! -> verified
Status: RESOLVED → VERIFIED
Component: Release Engineering: Custom Builds → Release Engineering: Releases
Product: mozilla.org → mozilla.org
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.