xpidl_java does not translate [noscript] method descriptions correctly

RESOLVED FIXED

Status

Core Graveyard
Java to XPCOM Bridge
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: Ashu Kulkarni, Assigned: Igor Kushnirskiy)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
BlackConnect does not support [noscript] and so all Non-scriptable 
methods should be dropped when translating the XPIdl Interfaces to 
Java. 

However, when xpidl_java is run on 
http://lxr.mozilla.org/mozilla/source/directory/xpcom/base/public/nsILDAPConnection.idl
a Non-scriptable method in the .idl file gets translated to Java as returning
a value of type "OpaqueType". This is a bug.

_Ashu
(Assignee)

Comment 1

17 years ago
nsIDLAPConnect.idl does not have no non-scriptable methods.
I was not able to reproduce the reported problem on other idl files
with non-scriptable methods.

I think that raporter did not use xpidl from java/xpcom/java/idl

Ashu, if I am right will you please close this bug as 'invalid'?
Status: NEW → ASSIGNED
(Assignee)

Comment 2

17 years ago
Reporter, will you please update the bug.
(Reporter)

Comment 3

17 years ago
Igor,

The LDAP interfaces have changed substantially in the last 2-3 months. None of 
the LDAP idl's now have non-scriptable methods. So the reasons for my filing 
this Bug no longer exist.

However, the problem in xpidl -m java still exists. I used my old version of 
nsILDAPConnection.idl and ran xpidl -m java on it. It still results in the 
noscript readonly attribute being converted into a java function 
with "OpaqueValue" as it's return type. Although I dont need this fixed 
anymore, there might be other users who need to work with .idl's containing 
noscript parameters, and for this reason the bug in xpidl should be fixed if 
possible.

I am attaching the old nsILDAPConnection.idl and the nsILDAPConnection.java 
that xpidl generates from it. I used the latest java/xpcom/java/xpidl code to 
generate my xpidl.exe.

thnx
_Ashu
(Reporter)

Comment 4

17 years ago
Created attachment 30617 [details]
old nsILDAPConnection.idl file
(Reporter)

Comment 5

17 years ago
Created attachment 30618 [details]
nsILDAPConnection.java generated by xpidl from the .idl file
(Assignee)

Comment 6

17 years ago
Created attachment 30622 [details] [diff] [review]
fix for the bug (diff -u)
(Assignee)

Comment 7

17 years ago
Thank you for the old nsILDAPConnection.idl

xpidl_java does not work properly in case [noscript] attributes.
Fix for the bug is  attached.
I am closing this bug as fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.