Last Comment Bug 674800 - Print address of XPTCStub with nsXPCWrappedJS, to help debugging
: Print address of XPTCStub with nsXPCWrappedJS, to help debugging
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla8
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-27 18:26 PDT by Alon Zakai (:azakai)
Modified: 2011-08-05 09:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (669 bytes, patch)
2011-07-27 18:26 PDT, Alon Zakai (:azakai)
mrbkap: review+
Details | Diff | Splinter Review

Description Alon Zakai (:azakai) 2011-07-27 18:26:24 PDT
Created attachment 549002 [details] [diff] [review]
patch

The attached patch prints out the XPTCStub's address when printing the nsXPCWrappedJS. This helps in debugging in situations where one might want to use the address of the stub and not the nsXPCWrappedJS itself.
Comment 1 Blake Kaplan (:mrbkap) 2011-08-01 15:29:36 PDT
Comment on attachment 549002 [details] [diff] [review]
patch

Only thought is that it might be more clear to add a "stub at" annotation so you don't have to remember which address is the wrappedJS vs. which is the stub each time. r=me either way if you prefer it this way strongly, though.
Comment 2 Alon Zakai (:azakai) 2011-08-04 15:05:27 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/b9e9b5a4959a

I prefer the shorter version, since these logs get extremely long as it is.
Comment 3 Marco Bonardo [::mak] 2011-08-05 09:00:06 PDT
http://hg.mozilla.org/mozilla-central/rev/b9e9b5a4959a

Note You need to log in before you can comment on or make changes to this bug.