RTL articles with previous approved revisions not-RTL don't show up in localization dashboards with the right significance

VERIFIED FIXED in 2011-08-09

Status

P1
normal
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: scoobidiver, Assigned: erik)

Tracking

unspecified
2011-08-09

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
https://support.mozilla.com/en-US/kb/getting-started-firefox-mobile has been marked as ready for localization, but it doesn't show up in localization dashboards as needing updates:
* https://support.mozilla.com/fr/localization/needing-updates
* https://support.mozilla.com/de/localization/needing-updates
There's no problem in locales where it's not localized:
https://support.mozilla.com/it/localization/untranslated

However, if you try to edit it in the locale, it shows the right English revision:
https://support.mozilla.com/fr/kb/debuter-avec-firefox-mobile/edit
(Reporter)

Comment 1

7 years ago
See also these articles:
* https://support.mozilla.com/en-US/kb/getting-started-firefox
* https://support.mozilla.com/en-US/kb/Deleting%20cookies
Summary: A ready-for-l10n article doesn't show up in localization dashboards as needing updates → Some ready-for-l10n articles don't show up in localization dashboards as needing updates
(Reporter)

Comment 3

7 years ago
I am unable to see the approval level but I think the latest revision of these articles was a minor change.
The problem is when there was an approved normal change not ready for localization before as in:
https://support.mozilla.com/en-US/kb/Deleting%20cookies/history
The most important approval level of the previous revisions not ready for localization must be taken into account, not only the level of the latest one.
Summary: Some ready-for-l10n articles don't show up in localization dashboards as needing updates → Articles with the latest ready-for-l10n revision as a minor change and a previous approved one not ready-for-l10n don't show up in localization dashboards as needing updates
Indeed. Here is how it should work:

If the latest revision is a 3rd level edit: business as usual

If the latest "ready for L10n" revision is either a minor edit or a second level edit, see if one of the earlier revisions that are approved, but not marked as ready for L10n, are of a higher level edit and use that level on the L10n dashboard.

Also, this should be fixed ASAP, the L10n dashboard loses a lot of functionality as it is.
Target Milestone: --- → 2011-08-02

Comment 5

7 years ago
Wording it a different way: if the latest revision marked RFL isn't translated, display on the l10n dashboard EXCEPT (if that one is trivial AND there are NOT untranslated approved minor/major revisions)
(Assignee)

Updated

7 years ago
Assignee: nobody → erik
(Assignee)

Comment 6

7 years ago
Topal: If the ready-for-l10n revision is of trivial significance but there has been a different revision of major significance since the last translation, the thing should be treated as major. Do I infer correctly?
Priority: -- → P1
Target Milestone: 2011-08-02 → 2011-08-09
Yes, absolutely
Verified:
- minor but RTL, in past there was approved major notRTL =show on localization dashboard in major section
- minor but RTL, no approval in history, then not on dashboard
- not translated, minor RTL = shows on 'needs update' dashboard
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

7 years ago
(In reply to Rebecca Billings from comment #8)
> Verified:
> - minor but RTL, in past there was approved major notRTL =show on
> localization dashboard in major section
> - minor but RTL, no approval in history, then not on dashboard
> - not translated, minor RTL = shows on 'needs update' dashboard
It depends on what you name minor.
Some name the three levels: minor, normal, major, others name them: trivial, minor, major.
(Reporter)

Comment 11

7 years ago
(In reply to Rebecca Billings from comment #8)
I guess here minor means level-1 here.
> - not translated, minor RTL = shows on 'needs update' dashboard
'untranslated' section?

Not verified for the following test cases:
* minor RTL, in past there was approved normal not-RTL
* normal RTL, in past there was approved major not-RTL
* normal RTL, no approval in history (non-regression)
* major RTL, no approval in history (non-regression)
Status: VERIFIED → RESOLVED
Last Resolved: 7 years ago7 years ago
Summary: Articles with the latest ready-for-l10n revision as a minor change and a previous approved one not ready-for-l10n don't show up in localization dashboards as needing updates → RTL articles with previous approved revisions not-RTL don't show up in localization dashboards with the right significance
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.