Last Comment Bug 674862 - nsResizerFrame may deanchor panels
: nsResizerFrame may deanchor panels
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Marco Bonardo [::mak] (Away 6-20 Aug)
:
Mentors:
Depends on:
Blocks: 652115
  Show dependency treegraph
 
Reported: 2011-07-28 03:48 PDT by Marco Bonardo [::mak] (Away 6-20 Aug)
Modified: 2011-08-01 03:56 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 (1.70 KB, patch)
2011-07-28 03:49 PDT, Marco Bonardo [::mak] (Away 6-20 Aug)
no flags Details | Diff | Splinter Review
patch v1.1 (1.80 KB, patch)
2011-07-28 03:50 PDT, Marco Bonardo [::mak] (Away 6-20 Aug)
enndeakin: review+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] (Away 6-20 Aug) 2011-07-28 03:48:13 PDT
Since it invokes nsMenuPopupFrame::moveTo that overrides mScreenXPos and mScreenYPos even if they are -1 (thus anchored).
Comment 1 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-07-28 03:49:10 PDT
Created attachment 549059 [details] [diff] [review]
patch v1.0
Comment 2 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-07-28 03:50:53 PDT
Created attachment 549060 [details] [diff] [review]
patch v1.1

the comment is now useless as well
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-07-29 02:40:02 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/f839abc8f150
Comment 4 :Ehsan Akhgari (away Aug 1-5) 2011-07-29 08:56:29 PDT
http://hg.mozilla.org/mozilla-central/rev/f839abc8f150
Comment 5 Jim Jeffery not reading bug-mail 1/2/11 2011-07-29 14:01:40 PDT
is it possible that this is causing ForecastFox to crash the browser when hovering over the icons when ForecastFox is placed in the application bar ? 

Crashing did not occur until I started using hourly build:
http://hg.mozilla.org/mozilla-central/rev/8fb752f5e1fa

Prior hourly build based on cset: 
http://hg.mozilla.org/mozilla-central/rev/f5f1e3822540 does not crash. 

Being as its an hourly build the crash-reports will be useless.
Comment 6 Jim Jeffery not reading bug-mail 1/2/11 2011-07-29 14:03:59 PDT
Forgot to mention in comment #5 above, I'm using m-c win32 builds and ForecastFox and Flashblock are the only addons I use.
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-08-01 03:38:00 PDT
(In reply to comment #5)
> is it possible that this is causing ForecastFox to crash the browser when
> hovering over the icons when ForecastFox is placed in the application bar ? 

Don't think so, the changes don't seem to be able to cause any new crash that could not happen before. If you can get a stack trace with next nightly may be useful.
Comment 8 Jim Jeffery not reading bug-mail 1/2/11 2011-08-01 03:56:52 PDT
(In reply to comment #7)
> (In reply to comment #5)
> > is it possible that this is causing ForecastFox to crash the browser when
> > hovering over the icons when ForecastFox is placed in the application bar ? 
> 
> Don't think so, the changes don't seem to be able to cause any new crash
> that could not happen before. If you can get a stack trace with next nightly
> may be useful.

Marco, thanks for the reply.  The issue with ForecastFox and some sites was caused by https://bugzilla.mozilla.org/show_bug.cgi?id=675437 which has a fix ready for review.

Sorry for barking up the wrong tree.

Note You need to log in before you can comment on or make changes to this bug.