Shortcut icon (favicon) remains in tab when BACK is used

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Rob Janssen, Unassigned)

Tracking

SeaMonkey 2.4 Branch
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0a2) Gecko/20110726 Firefox/7.0a2 SeaMonkey/2.4a2
Build ID: 20110726013002

Steps to reproduce:

Load some page that does not have a favicon (shortcut icon) in a tab.
The tab displays the default icon (the "bookmark" icon).
Click on a link or go to a bookmark, to a site that does have a favicon.
Then use the "BACK" button to go back to the original page.


Actual results:

The favicon for the second site is still displayed on the tab, which now displays the first site.
The "list all tabs" menu also has the wrong favicon.
The title on the tab changes correctly.


Expected results:

The favicon should change back to the default icon.

When the two pages used for the test both have a favicon, it works OK.

Comment 1

6 years ago
Neil says:
The favicon bug was caused by the fast back progress change. The favicon code assumes that the start document load clears out the old favicon, so it doesn't have to when the end document load happens. I guess you could condition the clearing of the favicon at the end of the document load on the restoring state.
(Reporter)

Comment 2

6 years ago
The bug is also present in the just-released version 2.4

Comment 3

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20110923 SeaMonkey/2.4
Tab preference set to "Hide the tab bar when only one tab is open."
Home page is exported bookmarks.  

I am seeing something that might be the same problem.  

1.  Select a link to a Web page that has a site icon.  

2.  Select the Back button on the toolbar.  

3.  Middle-click on another link (to open it in a new tab) that has a different site icon.  

Result:  The first tab (my internal bookmarks.html file) shows the site icon from step #1.  

Expected:  Since there is no site icon associated with my internal bookmarks.html file, the default icon (green ribbon?) should show on the first tab.
(Reporter)

Comment 4

6 years ago
(In reply to Philip Chee from comment #1)
> Neil says:
> The favicon bug was caused by the fast back progress change.

Well it was apparently easier to introduce than to fix.
Still present in 2.6.1 :-(

Updated

6 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

6 years ago
WORKSFORME with:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120319 Firefox/14.0a1 SeaMonkey/2.11a1
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

6 years ago
In the latest released Seamonkey (2.8) it is still broken.

Comment 7

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20120312 SeaMonkey/2.8

I confirm that this is indeed still a problem.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 8

6 years ago
It has been fixed in SeaMonkey/2.10
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME

Comment 9

6 years ago
Yes.  The problem I described in comment #3 appears fixed.
You need to log in before you can comment on or make changes to this bug.