TryServer sends 2 "Thanks for your try submission" emails per push

RESOLVED FIXED

Status

P5
normal
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tryserver][buildbotcustom])

(Reporter)

Description

7 years ago
Over the past few days, all of the TryServer builds that I've triggered have sent me two "Thanks for your try submission" emails.  They two emails are exactly the same.  e.g. the most recent one:
{
Thanks for your try submission (http://hg.mozilla.org/try/pushloghtml?changeset=aed73454d87a).  It's the best!

Watch http://tbpl.mozilla.org/?tree=Try&rev=aed73454d87a for your results to come in.

Builds and logs will be available at http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/dholbert@mozilla.com-aed73454d87a.

This directory won't be created until the first builds are uploaded, so please be patient.
}

I first saw this on 7/26 (and it's happened on every push since then).

My last "good" TryServer push was on 7/19.  So this duplicate-email issue appears to have been introduced between 7/19 and 7/26.
(Reporter)

Comment 1

7 years ago
(This appears to only affect the initial "Thanks" email.  I've only been getting getting 1 copy of the "build completed" emails (good).)
(Reporter)

Comment 2

7 years ago
jdm says he's hit this, too, so it's not just me.
those come from http://hg.mozilla.org/build/buildbotcustom/file/tip/status/generators.py whereas the rest of the emails are from try_mailer.py so something is running generators.py twice perhaps?
Priority: -- → P5
Whiteboard: [tryserver][buildbotcustom]
Has this been fixed?
I pushed to try and only got one email.
WFM too.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

7 years ago
Yup -- I haven't seen this in quite a while, & I forgot that the bug existed. :)
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
Saw this with five pushes today and nthomas asked me to file it.  A push at 12:54PM Eastern only sent one email; a push at 2:25PM Eastern sent two.

Example headers:

Return-Path: tryserver@build.mozilla.org
Received: from zmmta1.mail.corp.phx1.mozilla.com (LHLO
 zmmta1.mail.corp.phx1.mozilla.com) (10.20.77.21) by
 zmmbox6.mail.corp.phx1.mozilla.com with LMTP; Wed, 11 Sep 2013 11:25:18
 -0700 (PDT)
Received: from zmmta1.mail.corp.phx1.mozilla.com (localhost6.localdomain [127.0.0.1])
	by zmmta1.mail.corp.phx1.mozilla.com (Postfix) with ESMTP id D16461063E3
	for <nfroyd@mozilla.com>; Wed, 11 Sep 2013 11:25:18 -0700 (PDT)
Received: from smtp.mozilla.org (zlb1.mail.corp.phx1.mozilla.com [10.20.77.200])
	by zmmta1.mail.corp.phx1.mozilla.com (Postfix) with ESMTP id CE72610634D
	for <nfroyd@mozilla.com>; Wed, 11 Sep 2013 11:25:18 -0700 (PDT)
X-Virus-Scanned: amavisd-new at mozilla.org
Received: from buildbot-master81.srv.releng.scl3.mozilla.com (v-1030.fw1.releng.scl3.mozilla.net [63.245.214.82])
	by mx1.mail.corp.phx1.mozilla.com (Postfix) with SMTP id A7113F269C
	for <nfroyd@mozilla.com>; Wed, 11 Sep 2013 11:25:18 -0700 (PDT)
Content-Transfer-Encoding: base64
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Date: Wed, 11 Sep 2013 11:25:18 -0700
Subject: Try submission 6d8c5fb4f486
From: tryserver@build.mozilla.org
References: <try-6d8c5fb4f486>
In-Reply-To: <try-6d8c5fb4f486>
CC: 
To: nfroyd@mozilla.com
Message-Id: <20130911182518.CE72610634D@zmmta1.mail.corp.phx1.mozilla.com>

Return-Path: tryserver@build.mozilla.org
Received: from zmmta1.mail.corp.phx1.mozilla.com (LHLO
 zmmta1.mail.corp.phx1.mozilla.com) (10.20.77.21) by
 zmmbox6.mail.corp.phx1.mozilla.com with LMTP; Wed, 11 Sep 2013 11:25:09
 -0700 (PDT)
Received: from zmmta1.mail.corp.phx1.mozilla.com (localhost6.localdomain [127.0.0.1])
	by zmmta1.mail.corp.phx1.mozilla.com (Postfix) with ESMTP id EC5701063E8
	for <nfroyd@mozilla.com>; Wed, 11 Sep 2013 11:25:08 -0700 (PDT)
Received: from smtp.mozilla.org (zlb1.mail.corp.phx1.mozilla.com [10.20.77.200])
	by zmmta1.mail.corp.phx1.mozilla.com (Postfix) with ESMTP id E73181063E6
	for <nfroyd@mozilla.com>; Wed, 11 Sep 2013 11:25:08 -0700 (PDT)
X-Virus-Scanned: amavisd-new at mozilla.org
Received: from localhost6.localdomain6 (vpn1.releng.scl3.mozilla.com [63.245.214.124])
	by mx1.mail.corp.phx1.mozilla.com (Postfix) with SMTP id AA235F2728
	for <nfroyd@mozilla.com>; Wed, 11 Sep 2013 11:25:08 -0700 (PDT)
Content-Transfer-Encoding: base64
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Date: Wed, 11 Sep 2013 11:25:08 -0700
Subject: Try submission 6d8c5fb4f486
From: tryserver@build.mozilla.org
References: <try-6d8c5fb4f486>
In-Reply-To: <try-6d8c5fb4f486>
CC: 
To: nfroyd@mozilla.com
Message-Id: <20130911182508.E73181063E6@zmmta1.mail.corp.phx1.mozilla.com>

Can provide more headers upon request.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---
Seeing this on try pushes this morning still.
Very strange.

I see in the logs the email being sent at 11:25:18. I don't see the one from 11:25:08. Also, the one from 11:25:08 looks like it was sent by a VPN user.
Looks like these emails aren't being generated by releng. I think we have a good lead on where they're coming from, and are reaching out to them now.
should be good now.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.