Reduce the "Required properites[sic]" noise in the logs

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: lonnen, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
85% (2443299 lines / 2852556 total lines) of our Kohanna log file on stage are alerts for "alert: Required properites are missing from Could not find changeInRank - versions, versions_count". Another 12% (337219 line / 2852556 total lines) are for other forms of "alert: Require properites".

We should fix whatever is causing these, or if it is not a bug, prevent it from logging. The added noise can make it difficult to debug errors.

Comment 1

7 years ago
Sounds bad if you are not following the proper rites. :P
Jabba noticed it a while back in bug 628326 too
(Reporter)

Updated

7 years ago
Duplicate of this bug: 628326
(Reporter)

Comment 4

7 years ago
I dug into this and found out that the two properties causing most of the problems were added as part of a large (206 changed files with 14,112 additions and 8,611 deletions) change almost a year ago. Every row result from every call to the 201010/topcrash/sig/trend service is checked for certain properties and these two props are always missing.

I looked at the code paths that might use this variable down the line but didn't find anywhere using the keys causing the problems. Similar variable names are used all over the app but I think I checked them all and determined them to be unrelated. After my changes topcrashers still loads, as does the csv output, so I'm confident that these changes won't cause other problems.


rhelmer: r?
https://github.com/mozilla/socorro/pull/14
(Reporter)

Comment 5

7 years ago
Close that request because of the bad history stuff. 

rhelmer: r?
https://github.com/mozilla/socorro/pull/25
merged https://github.com/mozilla/socorro/commit/96061c28405f7c65a322121923809b00a91c44e7
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.