gfx form elements are not implementing active and hover

VERIFIED FIXED in M10

Status

()

Core
XUL
P3
normal
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: Kevin McCluskey (gone), Assigned: rods (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Gfx form elements do not honor hover and active.
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7
(Reporter)

Updated

19 years ago
Assignee: kmcclusk → pierre
Status: ASSIGNED → NEW
(Reporter)

Comment 1

19 years ago
Reassigning to Pierre

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Target Milestone: M7 → M8
(Reporter)

Updated

19 years ago
Assignee: pierre → kmcclusk
Status: ASSIGNED → NEW
(Reporter)

Comment 2

19 years ago
Pierre, I'm re-assigning back to me. I've already fixed this in my code
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
(Reporter)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

19 years ago
Added active and hover rules to ua.css for gfx-rendered radio buttons.
Added active and hover rules to ua.css for gfx-rendered checkbox.
Active and Hover are handled by the event-state manager so adding rules to
ua.css should be sufficient for all gfx-rendered widgets.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 4

19 years ago
ok, hover and active work on radio buttons and check boxes (and i assume
anything else you add a css rule for), but disabled still look clickable
onMouseOver.

if a radiobutton or checkbox is disabled, the hover and active properties
should never take effect.

reopening bug.
(Reporter)

Updated

19 years ago
Target Milestone: M8 → M9
(Reporter)

Comment 5

19 years ago
When in gfx-mode, the disabled radiobutton and checkbox can still be clicked on.
(Reporter)

Updated

19 years ago
Target Milestone: M9 → M10
(Reporter)

Comment 6

19 years ago
Moving to M10
(Reporter)

Updated

19 years ago
Assignee: kmcclusk → rods
Status: REOPENED → NEW
(Reporter)

Comment 7

19 years ago
Rod, re-assigning to you.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

19 years ago
The disable part of this buf is now covered under Bug 11466. This bug is fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
ok. marking verified fixed on

     1999-08-13-08 RedHat Linux 6.0 (GNOME/enlightenment)
     1999-08-13-08 WinNT 4.0 sp5
     1999-08-13-08 MacOS 8.51
You need to log in before you can comment on or make changes to this bug.