Stored passwords from desktop sites should auto-fill on mobile sites, and vice versa

RESOLVED DUPLICATE of bug 494593

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 494593
7 years ago
4 years ago

People

(Reporter: gunnaraas7, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20110729] )

(Reporter)

Description

7 years ago
Steps to reproduce: 
1. Login to a website that has both desktop and mobile versions (Twitter, Facebook, Tumblr, etc.) on Desktop
2. Sync login information
3. On mobile, change your user agent (using an add-on like phony) to Desktop Firefox, and go to the site that you logged into on desktop, and confirm that your login information has synced.
4. Switch your user agent back to default.
5. Your login information will not appear on the mobile site.

What should happen: 
Your login information should be available across both the desktop and mobile versions of the website.
(Reporter)

Updated

7 years ago
Whiteboard: [testday-20110729]
(Reporter)

Updated

7 years ago
Hardware: x86 → x86_64
Pretty sure this was aimed at Backend :)

(Though it's not really a Sync problem, this will suffice for now.)

I lean towards WONTFIX on this; to me it seems like a problem that sites should address (e.g., by sharing a login interface between desktop and mobile sites), rather than hacking something into Firefox, but I'm keen to hear other points of view.
Severity: normal → enhancement
Component: Firefox Sync: Build → Firefox Sync: Backend
OS: Windows 7 → All
QA Contact: sync-build → sync-backend
Hardware: x86_64 → All
It's not even so much about interface sharing as domain sharing.  If I have login.foo.com on desktop, and redirect to m.foo.com on mobile, there's no standard way to know that both login.foo.com and m.foo.com should be treated as the same domains for password autofill purposes.  This might just be a password manager bug/RFE, but I don't think Sync can solve this.

(The same problem exists for, say, mail.google.com and google.com/accounts)
(In reply to comment #2)
> It's not even so much about interface sharing as domain sharing.

That's what I mean by "login interface". Engineer level of abstraction :)
(Reporter)

Comment 4

7 years ago
I have an idea for a way this could be done. Say a username and password is saved for example.com, what if with that we also check if common sub-directories like m.example.com and mobile.example.com exist on that domain. If they do exist, the information that was saved for example.com could be copied over to subdirectory.example.com
(Reporter)

Comment 5

7 years ago
*edit,
common sub-domains.
Also, because of privacy issues, there could be a notification on m.example.com such as "We have noticed you have saved login credentials for example.com, would you like to login with these credentials on m.example.com?"
Gonna throw this at Password Manager, 'cos how the passwords end up in your database doesn't affect the issue.
Component: Firefox Sync: Backend → Password Manager
Product: Mozilla Services → Toolkit
Summary: Synced login information should go to desktop sites and mobile sites → Stored passwords from desktop sites should auto-fill on mobile sites, and vice versa
This is something we're looking at: both through pre-defined "realms" and allowing the user to choose from credentials on subdomains.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 494593
You need to log in before you can comment on or make changes to this bug.