ff 5 hangs when downloading

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: u314746, Unassigned)

Tracking

5 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

tried to download a file or image


Actual results:

the browser hangs and then windows 7 become unresponsive.  It gets bad enough that I cannot even ctr-alt-del and have to restart by turning it off the power.  I'm getting disk corruption also, severe enough disk problems that I'm unable to boot windows 7 and need to boot from a different install and run chkdsk.  One chkdsk took 45 minutes to complete as it had enough problems.

I have not had such problems in the past when losing power.  Things work fine in FF 4 and things work fine in FF 5, until I download a file or image.  I don't know if the extensions are a problem as currently I am reluctant to turn off the extensions and download with FF 5 due to corruption problems.

I realize this might not be optimal but is a serious issue such that I cannot use FF 5.
(Reporter)

Comment 1

7 years ago
I do not see the problem when using explorer, only FF 5.

Comment 2

7 years ago
Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile?
https://support.mozilla.com/en-US/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Firefox can not hang/freeze or crash the OS. A usermode application doesn't have the system privileges to do that but Firefox could trigger a bug in a driver or other software with kernelmode privileges (drivers, Firewall products, Antivirus software).

Firefox calls the installed Antivirus software for a scan after the download.
Is it possible that your AV software is causing this ?
Please open about:config, confirm the warning, enter "scan" in the top filter bar and change "browser.download.manager.scanWhenDone" to false.
(Reporter)

Comment 4

6 years ago
Not sure why, but it went away as suddenly as it showed up.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.