Message Filter not applied correctly but works if applied manually afterwards

UNCONFIRMED
Unassigned

Status

SeaMonkey
MailNews: General
UNCONFIRMED
7 years ago
5 years ago

People

(Reporter: fhgnne, Unassigned)

Tracking

SeaMonkey 2.2 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2
Build ID: 20110706120824

Steps to reproduce:

I create a Message Filter for a POP3 Account (old Filters, that worked with previous Seamonkey and Mozilla Versions!), that contains two Filter Lines:
"Apply Filters when Checking Mail or Manually Run"
"Match all of the following"
Subject contains "Test"
Received contains "servername"


Actual results:

When retrieving the Messages from the POP3 Server, the filter is not applied
When selecting
Run selected filter(s) on "Inbox" + "Run now" it works fine.
Other filters work fine, independent on the number of filter lines



Expected results:

The filters should be applied on direct download of the Messages - as it worked before on the older versions!

Comment 1

7 years ago
I have the same issue. It appeared when I upgraded from 2.0.x to 2.2.
Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110706 Firefox/5.0 SeaMonkey/2.2

When downloading messages from a POP3 server (manually in my case, I do not have automatic download enabled) some filters are applied to one message but not to other messages. Sometimes the filter is applied to more than one message. 

Some filters fail on a "Subject" or "Reply-To" "contains" header.

If I run filters manually (Tools->Run Filters on Folder) all messages are properly filtered.

Updated

5 years ago
Whiteboard: [dupeme?]
You need to log in before you can comment on or make changes to this bug.