If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Japanese characters are displayed in every other line

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Tomoo Nomura, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
A received mail which contains Japanese language is displayed in every other
line. One space line is inserted after every line.
And moreover, these messages could not be cut & pasted. It causes Mozilla crash,
even if it is once pasted on notepad and cut them to paste new message window.
However, it is possible to cut & paste each line one by one. I suppose it has an
illegal character at the end of each line.

Comment 1

17 years ago
Reporter can you attach the mail where this happened? Can you reproduce it? What
build were you using?
I'm pretty sure this is a duplicate.  

momoi would know for sure.

Comment 3

17 years ago
This seems to be a dulicate of:

http://bugzilla.mozilla.org/show_bug.cgi?id=63081

The fix for this problem went in on 1/23/2000. So we have additional
problems we need to identify the conditions under which 
the problem still occurs.

nomura-san, can you provide a test case in the form of
attachment? I am not seeing this problem when the message
is of the type for which the original bug was reported. 
Non-flowed, plain text msgs.
(Reporter)

Comment 4

17 years ago
Created attachment 24743 [details]
Unzip, move check1 to mail folder, launch Mozilla 0.7, open check1 folder, choose a message, you will see, copy some lines from the message, paste them on a new message window.

Comment 5

17 years ago
I am not able to reproduce the problem with the attached
test file. Nor could I reproduce the crash when copy/pasting
the original data.

Nomura-san, please indicate which day's build you are using.
That critical information is missing fromy our original bug
report. 
You will see the build date when you use the menu: "HELP | About Mozilla".
(Reporter)

Comment 6

17 years ago
I am using Mozilla 0.7
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.7) Gecko/20010109

Comment 7

17 years ago
You said the magic word:

Gecko/20010109

That is a build from Jan. 9, 2001. 
The problem was not fixed until Jan. 23, 2001. 

Please try the latest build. You should not see the
problem. In general, please report a bug only after
you are able to reproduce it on the latest daily build.

Marking it resolved as Worksforme. If you find the problem
with the latest build, please re-open.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
I confirmed it has been settled in Mozille M18 Gecko/20010207
Thanks.

Comment 9

17 years ago
Marking verified based on reporter's and momoi's comments 2/07-08
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

17 years ago
As Momoi mentioned, it had been fixed before I submitted the report. This
article should be closed.
Note: The similar bug in case of HTML mail was reported by 70431, and it is
still open.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.