Closed Bug 675460 Opened 9 years ago Closed 9 years ago

Task View filters only consider percent completed when filtering by completed status

Categories

(Calendar :: Tasks, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mmecca, Assigned: mmecca)

Details

Attachments

(1 file)

The Completed Tasks and Incomplete Tasks filters in the Task View are only filtering based on the PERCENT-COMPLETE property. This works fine for tasks modified locally since we set PERCENT-COMPLETE to 100 when marking a task completed, but some other providers like Remember the Milk don't always set this property on completion. From my understanding of the spec the PERCENT-COMPLETE is not required to have status completed.
Assignee: nobody → matthew.mecca
Status: NEW → ASSIGNED
Attached patch Fix v1Splinter Review
Use isCompleted instead of percentCompleted in filters to check completed status.
Attachment #549621 - Flags: review?(philipp)
Thank you for this fix. 

Two questions : 
1 - How do I install this fix ? 
2 - Is there any mean to get "categories" from Remember the milk to be visible in lightning ?
(In reply to comment #2)
> Thank you for this fix. 
> 
> Two questions : 
> 1 - How do I install this fix ? 
You need to manually apply this patch to the files in the .xpi. If this is too much, then you have to wait until this bug is marked FIXED + one day and then use a nightly build (of both Thunderbird and Lightning)

> 2 - Is there any mean to get "categories" from Remember the milk to be
> visible in lightning ?
Unless RTM exports categories, this won't work. Since you ask, it seems they don't.
Hi, 

@Matthew : I applied the fix, but it do not work on my data. 
I'v seen that modification have been applied in 'calFilter.js', but there are comment that say '// a number of prefined Filters for properties' --> is there anywhere else where filters are defined ? 

@Philipp : it will be great if there were any module to RTM. unfortunately, I have no time for development, but I have some for test if you need to.
(In reply to comment #4)
> @Philipp : it will be great if there were any module to RTM. unfortunately,
> I have no time for development, but I have some for test if you need to.
Sorry, this is not something I will be pursuing in the near future.
(In reply to comment #4)

> @Matthew : I applied the fix, but it do not work on my data. 

It works for me as far as the filters go - are you sure the patch was applied correctly?

I do get an XML error when I try to complete or modify an RTM task, and then the calendar refuses to load again, but this is a separate issue. I'm not an RTM user so I'm not sure if this is a regression or if it ever worked.
(In reply to Matthew Mecca [:mmecca] from comment #6)
> (In reply to comment #4)
> 
> > @Matthew : I applied the fix, but it do not work on my data. 
> 
> It works for me as far as the filters go - are you sure the patch was
> applied correctly?
> 
> I do get an XML error when I try to complete or modify an RTM task, and then
> the calendar refuses to load again, but this is a separate issue. I'm not an
> RTM user so I'm not sure if this is a regression or if it ever worked.

Hi, I found why the patch didn't work --> I applied it on the wrong calFilet.js file. 
On windows, there is 2 copy of calFilter.js : in "\chrome\calendar\content\calendar" and in "\calendar-js". I applied the patch on the second one while the first one is used. 
@developers : can you explain me why there 2 calFilter.js files ?

@Mattew : patch works for me now
Comment on attachment 549621 [details] [diff] [review]
Fix v1

r=philipp

If you think this is safe for 1.0, push to all three trees, otherwise comm-central only.
Attachment #549621 - Flags: review?(philipp) → review+
Matthew, do you need assistance for checkin?
Pushed to comm-central - http://hg.mozilla.org/comm-central/rev/34ccc9dc9320
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
You need to log in before you can comment on or make changes to this bug.