Plugin-container badly needs some form of memory management

RESOLVED DUPLICATE of bug 501485

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 501485
7 years ago
7 years ago

People

(Reporter: IU, Unassigned)

Tracking

({memory-footprint})

Trunk
x86
Windows XP
memory-footprint
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [MemShrink])

(Reporter)

Description

7 years ago
After viewing a lot of flash videos, the plugin-container process will have memory consumption in the hundreds of megabytes.  500+ to 700+ MB is not uncommon for me.  I believe I may have even surpassed 1 GB the odd time.

This memory is never freed (even after all flash-containing tabs are closed) -- short of killing plugin-container or restarting the browser.  If you simply watch a few short videos, closing the tab after each, the memory is freed; however, if you watch a large number of videos over time, including occasionally having more than one tab open with a flash video (even though only one video is playing), consumed memory is not freed with tab closing.

From rudimentary testing I have done, comparing memory consumption of plugin-container between silverlight videos at http://www.bing.com/videos/browse and flash videos at http://www.youtube.com and other sites, it appears this might be a problem with the flash plugin, as I don't observe this with silverlight.

I have observed this with flash player 10.2+ (don't remember if I have experienced this with previous flash player versions), as Firefox's memory consumption generally got really bad with Firefox 4, and I was using flash player 10.2 by then.  One thing I know for sure is that I did not experience this problem with Firefox 3.6 and flash player 10 and 10.1.

That said, I'm hoping there's a way Firefox can force plugin-container to release memory when.
(Reporter)

Updated

7 years ago
Keywords: footprint
(Reporter)

Updated

7 years ago
Whiteboard: MemShrink

Comment 1

7 years ago
maybe bug 501485 can help
(Reporter)

Comment 2

7 years ago
Thanks, Jo.  I'll add that as a dependency.
Depends on: 501485
Setting plugins.unloadASAP;true (that hidden Pref got introduced in Bug 500925 - see also http://mxr.mozilla.org/mozilla-central/source/dom/plugins/base/nsPluginHost.cpp#329) terminates the plugin-container Process instantly as soon as a Plugin containing Tab gets closed and thus releases its occupied Memory.

Reading the surrounding Bug Reports this could have Side Effects though ...
(Reporter)

Comment 4

7 years ago
Thanks for the info.  I've enabled plugins.unloadASAP and see that it's a bit too aggressive."  A 5 to 10 second delay would have been nice.  I use the Stop AutoPlay extension and upon initially loading a non-whitelisted page with flash, plugin-container.exe quickly appears and exits.  However, given that a solution from bug 501485 is nowhere on the horizon, and I deny most sites from running flash automatically, setting the pref is bearable.
Whiteboard: MemShrink → [MemShrink]
I think this is pretty much the same as bug 501485, since the tweaking the unload policy is the only way we can change things here.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501485
You need to log in before you can comment on or make changes to this bug.