Last Comment Bug 675485 - Fix PRBool misuses found in a debug build
: Fix PRBool misuses found in a debug build
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Rewriting and Analysis (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Michael Wu [:mwu]
:
Mentors:
Depends on: 669808
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-31 00:12 PDT by Michael Wu [:mwu]
Modified: 2011-08-02 03:44 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix (1.71 KB, patch)
2011-07-31 00:12 PDT, Michael Wu [:mwu]
bzbarsky: review+
taras.mozilla: review+
Details | Diff | Splinter Review

Description Michael Wu [:mwu] 2011-07-31 00:12:52 PDT
Created attachment 549634 [details] [diff] [review]
Fix

Found by boolcheck. Some of these were missed the first time due to my mozconfig not matching the tinderbox debug mozconfig.

bz:
 layout/generic/nsFrame.cpp                           |    4 ++--
 tools/trace-malloc/leaksoup.cpp                      |    2 +-

taras:
 startupcache/StartupCache.cpp                        |    2 +-
Comment 1 Boris Zbarsky [:bz] 2011-08-01 07:29:28 PDT
Comment on attachment 549634 [details] [diff] [review]
Fix

r=me
Comment 3 Marco Bonardo [::mak] 2011-08-02 03:44:40 PDT
http://hg.mozilla.org/mozilla-central/rev/d11aaaf51059

Note You need to log in before you can comment on or make changes to this bug.