new java plugin installed while browser is running becomes active but is not picked up by addons manager

VERIFIED DUPLICATE of bug 554780

Status

()

Toolkit
Add-ons Manager
VERIFIED DUPLICATE of bug 554780
7 years ago
7 years ago

People

(Reporter: aceman, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
What happened:
0. I have java plugin normally disabled (see screenshot 1).
1. while Frefox 7.0a2 was running, I updated the JRE 1.6u25 to JRE 1.6u26. That also updated the FF Java plugin.
2. I noticed on one site, that it can enumerate my enabled plugins and it also saw my Java plugin (see attachment 2 [details] [diff] [review]). That was strange, I went to addons manager and the plugin (1.6u25) was still disabled (screenshot 1).
3. However, going to about:plugins revealed (screenshot 3) that now I have 1.6u26 activated and that is what the site saw.

So that means Firefox was re-enumerating available plugins while it was running, but the addons manager didn't pick up the changes. That is bad, the user is misled about what plugins Firefox is really using.
(Reporter)

Comment 1

7 years ago
Created attachment 549643 [details]
Screenshot 1 - addon manager
(Reporter)

Comment 2

7 years ago
Created attachment 549644 [details]
Screenshot 2 - site plugin enumeration via JS
(Reporter)

Comment 3

7 years ago
Created attachment 549645 [details]
Screenshot 3 - about:plugins
(In reply to comment #0)
> 1. while Frefox 7.0a2 was running

This would be the cause. The Addons Manager currently assumes only it will make changes to plugins while Firefox is running.

I assume the webpage you tested on called nagivator.plugins.refresh() before getting the list of enabled plugins?
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 554780
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.