can't send HTML e-mail in version 5.0

RESOLVED WORKSFORME

Status

Thunderbird
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: vicsage, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 549672 [details]
HTML issue before and after.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

I've attempted (in multiple times in multiple ways) to send HTML formatted e-mail. Every time it strips the HTML formatting and sends the mail in plain text. 


Actual results:

Typically I use plain text, so it hasn't been a big issue, but every once in a while, I need to send out formatted text. 

I can compose in HTML (either by holding "Shift" before writing/replying -- as I have my system set to compose in plain text) or by setting it compose in HTML via Tools>Account Settings>Composing and Addressing>Compose Message in HTML format.

When I'm writing the message, I get the HTML form/template and everything looks fine. I get different colours, bullets, italics, etc. Then I hit "send" and the message that gets sent out is stripped of all of that. The copy in my "Sent" folder is plain text. The copy that arrives at the destination is plain text.

Right now I have the send option set to "send the HTML anyway" in the case of people who can't receive HTML. I've also had it set at "send both HTML and plain text" although I can't see why it would make a difference, as I don't have any addresses saved under "can't receive HTML." 

System info: Win 7 64-bit


Expected results:

HTML-formatted text should have been sent out.
(Reporter)

Comment 1

7 years ago
Here is the header info from the Sent item:

From - Sun Jul 31 13:54:51 2011
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00800000
X-Mozilla-Keys:                                                                                 
Message-ID: <4E3596E9.2040607@XXXXXXXXX.XXX>
Date: Sun, 31 Jul 2011 13:54:49 -0400
From: XXXXXXXXXXX [name and address redacted for security]
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20110624 Thunderbird/5.0
MIME-Version: 1.0
To: vicsage@XXXXX.XXX
Subject: HTML problem demonstration
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit

Sample problem.
/Here is the draft version of my e-mail. /
*I have
*

  * *written this with HTML formatting applied*
  * *saved a screen cap of this before sending*


    I will take another screencap of this once it has been sent and is
    in my Sent folder.
Do you have the issue if you start Thunderbird in -safe-mode ( see http://support.mozillamessaging.com/en-US/kb/Safe-Mode ) ?
(Reporter)

Comment 3

7 years ago
I have no idea. I never tried it. Actually, I was unaware of that option. Thanks for the information. It will come in handy, should I encounter other issues. 

Instead, I uninstalled the program, then reinstalled it. The problem seems to have vanished. I didn't to anything differently the second time around. I didn't change any of the settings. I can't account for it.
dup of bug 414299?
(In reply to WADA from comment #4)
> dup of bug 414299?

as the reporter can't reproduce I'll mark this one WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.